Bug 135022 - LibreOffice Crashes when Redoing Zotero Actions.
Summary: LibreOffice Crashes when Redoing Zotero Actions.
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Crash-BigPtrArray
  Show dependency treegraph
 
Reported: 2020-07-21 15:41 UTC by Clarc
Modified: 2020-09-14 09:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clarc 2020-07-21 15:41:19 UTC
Description:
I'm on Linux Mint 20 and use the version: 6.4.5.2, Zotero plugin installed.

When undoing a deleted Zotero-Bibliography, LibreOffice crashes.

Steps to Reproduce:
1. Write Text
2. Add a Citation (via Zotero) somewhere.
3. Create a Bibliography (via Zotero) at the end of the document.
4. Delete the bibliography
5. Insert another Bibliography (via Zotero) a few lines of text above the spot where the old one was.
6. Undo twice, so that LibreOffice has to recreate the fist Bibliography.
7. LibreOffice crashes.

Actual Results:
LibreOffice crashes.

Expected Results:
1. Best case: Reconstructing the Bibliography.
2. Second Option: LibreOffice announcing "sorry, this doesn't work. Please insert another Bibliography by yourself"


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Inserting Zotero-Bibliographies mid-text generally seems a little... off.
Sometimes the Box around the Zotero-Bibliography is out of place, with either the whole content coming after the box, or the Box only containing, for example, the first entry.
I understand this isn't a everyday problem... should I still file a Bug?

Version: 6.4.5.2
Build ID: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Flatpak
Locale: de-AT (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-08-05 15:00:36 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 yehim83708 2020-08-11 07:41:13 UTC
(In reply to Xisco Faulí from comment #1)
> Thank you for reporting the bug. Please attach a sample document, as this
> makes it easier for us to verify the bug. 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' once the requested document is provided.
> (Please note that the attachment will be public, remove any sensitive
> information before attaching it. 
> See
> https://wiki.documentfoundation.org/QA/
> FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help
> on how to do so.)

Hey, I'm the original poster... I can't find my account details anymore though, so i'm answering using this temporary accout.

I'm currently not at my own pc, but when I tested this issue (a few weeks ago in LibreOffice 6.4.5.2), i could replicate this bug with a completely fresh document, no special changes except for maybe setting the written language to german.

In this case, do you still need a sample document? It should in theory work with any new document.
(obviously you need to write a few lines of text so you can follow the Steps to Reproduce)