Bug 135081 - After hiding the last paragraph's text, not possible to unhide it, because you can't select that paragraph
Summary: After hiding the last paragraph's text, not possible to unhide it, because yo...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Effects Selection
  Show dependency treegraph
 
Reported: 2020-07-23 17:24 UTC by LeroyG
Modified: 2022-08-31 17:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Situation after ctrl+A (107.87 KB, image/png)
2020-08-03 09:27 UTC, Heiko Tietze
Details
Screenshots (32.55 KB, image/png)
2022-08-04 22:12 UTC, LeroyG
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LeroyG 2020-07-23 17:24:40 UTC
Description:
When font effect of last paragraph is set to hidden, is not possible to unhide it; neither possible to select all if last visible "paragraph" is a table.

Steps to Reproduce:
1. Create a file.
2. Add a paragraph (press Enter).
3. Hide the last paragraph (menu `Format` - `Character…` - `Font Effect` tab - check `Hidden`.
4. `Select All`.
(5. Unhide the last paragraph (menu `Format` - `Character…` - `Font Effect` tab - uncheck `Hidden`.)

Actual Results:
`Select All` do not include last paragraph (so, not possible to unhide it).

Expected Results:
`Select All` must include last paragraph (to unhide it).


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
If last visible "paragraph" is a table, you can't even Select All.
Comment 1 LeroyG 2020-07-23 18:28:20 UTC
Ennabling `Hidden characters` (menu `Tools` - `Options…` - `LibreOffice Writer` - `Formatting Aids` - `Display formatting` allows to `Select All`.
Comment 2 Dieter 2020-07-31 09:51:31 UTC
I confirm it with

Version: 7.0.0.0.beta2 (x64)
Build ID: 1c213561a365b5666167321de68c9977500c9612
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

I also had a look at LO help [1]. It says about Hidden Option: "Hides the selected characters. To display the hidden text, ensure that Formatting Marks is selected in the View menu. You can also choose Tools - Options - LibreOffice Writer - Formatting Aids and select Hidden characters." But I couldn't make it visible with Formating Marks or setings in Options. So I'm not sure, if this is another bug (and to solve this bug would also solve the prolem that is described here) or is LO Help wrong.

=> Design-Tea for further input

[1] https://help.libreoffice.org/7.0/en-GB/text/shared/01/05020200.html?System=WIN&DbPAR=WRITER&HID=cui/ui/effectspage/EffectsPage#bm_id3147090
Comment 3 Heiko Tietze 2020-07-31 12:31:43 UTC
On macOS I select all per cmd+A and get the hidden checkbox in the third, indefinite state. But IIRC you are able to select the last character with shift right in addition (have to test later with Linux).

Issue with hidden text is weird, indeed. Didn't we change something around this recently?
Comment 4 Dieter 2020-07-31 12:37:14 UTC
(In reply to Heiko Tietze from comment #3)
> But IIRC you are able to select the last character with
> shift right in addition (have to test later with Linux).

Doesn't work with Windows 10.
Comment 5 Heiko Tietze 2020-08-03 09:27:28 UTC
Created attachment 163894 [details]
Situation after ctrl+A

Dummy text with last sentence hidden. Ctrl+A selects all and the properties dialog shows the indetermined state.

Version: 7.1.0.0.alpha0+
Build ID: e865acdcc9321a08fac00bd1fb2c27a7580d3cec
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Heiko Tietze 2020-08-03 09:41:06 UTC
(In reply to Dieter from comment #2)
> I also had a look at LO help [1]. It says about Hidden Option: "Hides the
> selected characters. To display the hidden text, ensure that Formatting
> Marks is selected in the View menu. You can also choose Tools - Options -
> LibreOffice Writer - Formatting Aids and select Hidden characters." But I
> couldn't make it visible with Formating Marks or setings in Options. So I'm
> not sure, if this is another bug (and to solve this bug would also solve the
> prolem that is described here) or is LO Help wrong.
> 
> => Design-Tea for further input

Would treat this as a separate issue. See also bug 130688, bug 98528, bug 102346, and bug 81692. As well as bug 107658 and bug 107722.
Comment 7 QA Administrators 2022-08-04 03:34:43 UTC Comment hidden (obsolete)
Comment 8 Dieter 2022-08-04 12:32:43 UTC
Still same behaviour

Version: 7.3.5.2 (x64) / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 9 LeroyG 2022-08-04 22:12:54 UTC
Created attachment 181619 [details]
Screenshots

(In reply to comment #0)
> 3. Hide the last paragraph

If do you hide both paragraphs, things become better. :-)

(In reply to comment #1)
You MUST enable `Hidden characters` (menu `Tools` - `Options…` - `LibreOffice Writer` - `Formatting Aids` - `Display formatting`) to `Select All`.

Version: 7.2.7.2 (x64) / LibreOffice Community
Build ID: 8d71d29d553c0f7dcbfa38fbfda25ee34cce99a2
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: es-MX (es_ES); UI: en-US
Calc: CL

Tomorrow I will try to test in version 7.4.
Comment 10 stragu 2022-08-31 17:12:59 UTC
Also in:

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 24087697d5cf78aac346d4dcea0596373e15a95c
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded