Download it now!
Bug 135096 - Empty image frames shown after saving to ODT (tracking changes enabled). File reload solves it
Summary: Empty image frames shown after saving to ODT (tracking changes enabled). File...
Status: RESOLVED DUPLICATE of bug 138785
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-07-24 11:46 UTC by Telesto
Modified: 2020-12-14 09:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (19.12 MB, application/vnd.oasis.opendocument.text)
2020-07-24 11:47 UTC, Telesto
Details
Example file (9.28 MB, application/vnd.oasis.opendocument.text)
2020-07-28 09:09 UTC, Telesto
Details
Example file (95 pages) (5.03 MB, application/vnd.oasis.opendocument.text)
2020-12-07 18:36 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-24 11:46:59 UTC
Description:
Missing images after save to ODT (tracking changed hide)

Steps to Reproduce:
1. open the attached file
2. Select everything from H8 to bottom
3. Press backspace
4. Scroll again to bottom to delete page cover anchored to page
5. Save as -> Pick a file name ODT
6. Scroll up/ frames without images

Actual Results:
Frames without images

Expected Results:
Image still around


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-24 11:47:41 UTC
Created attachment 163476 [details]
Example file
Comment 2 raal 2020-07-27 16:03:41 UTC
(In reply to Telesto from comment #0)

> 2. Select everything from H8 to bottom


Hello, what is H8? Thank you
Comment 3 Telesto 2020-07-28 09:09:06 UTC
Created attachment 163675 [details]
Example file

Smaller file 
1. Open the attached file
2. Scroll to bottom and delete the image on the second last page 
3. Save -> Images gone
Comment 4 Telesto 2020-07-28 09:32:26 UTC
Also in
6.0.0.3

and in
Versie: 5.1.6.2 
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: GL; 
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 5.0.0.1 
Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Locale: nl-NL (nl_NL)

also in 4.4.7.2 (but a lot less; found 1 empty frame; probably slower timers)

empty frames using the large file with
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba


no repro with
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 5 Buovjaga 2020-12-07 17:38:57 UTC
Not seeing the problem. Could you perhaps try to minimise the file, so it is simpler to test?

Arch Linux 64-bit
Version: 7.2.0.0.alpha0+
Build ID: 43d07ddf487fae1b966abf00a36612b109ed01fc
CPU threads: 8; OS: Linux 5.9; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 7 December 2020
Comment 6 Telesto 2020-12-07 18:36:28 UTC
Created attachment 167912 [details]
Example file (95 pages)

Reducing files without knowledge about the cause kind of hard.. 
1. open the attached file
2. Go to page 94 & delete the cover
3. Save the file (not save as. 

Notice missing image on page 93
Comment 7 Telesto 2020-12-07 19:23:59 UTC
(In reply to Telesto from comment #6)
> Created attachment 167912 [details]
> Example file (95 pages)
> 
> Reducing files without knowledge about the cause kind of hard.. 
> 1. open the attached file
> 2. Go to page 94 & delete the cover
> 3. Save the file (not save as. 
> 
> Notice missing image on page 93

FWIW. Maybe even different bug, not reproducible with 6.2
Comment 8 Buovjaga 2020-12-14 06:57:05 UTC
(In reply to Telesto from comment #3)
> Created attachment 163675 [details]
> Example file
> 
> Smaller file 
> 1. Open the attached file
> 2. Scroll to bottom and delete the image on the second last page 
> 3. Save -> Images gone

Thanks, this is much better and I can reproduce. For the record, I tried again today with the original file with the exact same steps and could *not* reproduce.

Bibisected with linux-64-7.1 to https://git.libreoffice.org/core/commit/b9ef71476fd70bc13f50ebe80390e0730d1b7afb
tdf#134298 sw: layout: remove left-over page frame without content

But now I see this has already been bibisected in bug 138785, just with a different file.

Can you really repro with the original file with a fresh master build?
Comment 9 Telesto 2020-12-14 09:19:07 UTC
Repro
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 35e471bb4d1388cf5afcdcee214cf5111edf44e3
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

@Buovjaga
Sorry for wasting your time with the bibisect.. reported this twice indeed :-(

*** This bug has been marked as a duplicate of bug 138785 ***