Download it now!
Bug 135097 - DOCX: Delete the image caption frame doesn't delete the image
Summary: DOCX: Delete the image caption frame doesn't delete the image
Status: RESOLVED DUPLICATE of bug 135149
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-07-24 12:09 UTC by Telesto
Modified: 2020-11-17 10:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (2.20 MB, application/vnd.oasis.opendocument.text)
2020-07-24 12:09 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-24 12:09:06 UTC
Description:
DOCX: Delete the image caption frame doesn't delete the image 

Steps to Reproduce:
1. Open the attached file
2. Export to DOCX
3. Delete the toolbar image frame on top of the page
4. Frame goes away, image still around

The export filter is not the issue;

Actual Results:
Frame goes away, image still around

Expected Results:
Image and frame go away


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

also in
4.4.7.2

crash in 4.3

fine in 4.2
Comment 1 Telesto 2020-07-24 12:09:24 UTC
Created attachment 163477 [details]
Example file
Comment 2 Attila Baraksó (NISZ) 2020-10-25 10:03:02 UTC
Fine in:

Version: 7.1.0.0.alpha0+
Build ID: f1d798151048dde3f48b124ef406416668d1e9c5
CPU threads: 6; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded
Comment 3 Attila Baraksó (NISZ) 2020-11-17 10:26:43 UTC
Looks like this is fixed in master, fine in:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: 312a33b7636334f6ce3b6d1702bc5d3e45215601
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded
Comment 4 Attila Baraksó (NISZ) 2020-11-17 10:29:50 UTC
Reverse bibisected using bibisect-win64-7.1 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit?id=da4f9b77a6cd39b1ae5babdd476d1575c8b9371c
author: Miklos Vajna <vmiklos@collabora.com>
committer: Miklos Vajna <vmiklos@collabora.com>
summary: tdf#135149 sw: fix deleting textbox of as-char shapes
Comment 5 Attila Baraksó (NISZ) 2020-11-17 10:30:19 UTC

*** This bug has been marked as a duplicate of bug 135149 ***