Bug 135135 - Fileopen .docx: grouped object that forms the table not as expected, cannot type
Summary: Fileopen .docx: grouped object that forms the table not as expected, cannot type
Status: RESOLVED DUPLICATE of bug 118693
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Grouped-Shapes
  Show dependency treegraph
 
Reported: 2020-07-25 16:48 UTC by luigisic
Modified: 2021-03-18 09:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File .docx (129.11 KB, application/zip)
2020-07-25 16:49 UTC, luigisic
Details
File .pdf to compare layout (89.49 KB, application/pdf)
2020-07-25 16:50 UTC, luigisic
Details
File 1st page compared MSO LO (95.90 KB, image/png)
2020-07-27 21:02 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description luigisic 2020-07-25 16:48:01 UTC
Description:
File .docx is not processed as expected.
I attach a .pdf version of the same .docx file to see.
Thanks

Steps to Reproduce:
1. Open file.
2.
3.

Actual Results:
Wrong layout. 
On the first page there is a grid that is mistaken for an image.
On the second page the first grid is mistaken for an image, so the second grid is Ok.

Expected Results:
All grids are shown correctly as in the attached .pdf file


Reproducible: Always


User Profile Reset: No



Additional Info:
No more information.
Comment 1 luigisic 2020-07-25 16:49:59 UTC
Created attachment 163532 [details]
File .docx
Comment 2 luigisic 2020-07-25 16:50:39 UTC
Created attachment 163533 [details]
File .pdf to compare layout
Comment 3 luigisic 2020-07-27 06:30:05 UTC
Hello,
  by grid I meant a table.
Thanks
Comment 4 Timur 2020-07-27 21:02:00 UTC
Created attachment 163658 [details]
File 1st page compared MSO LO

This is a classic wrong way to report a bug "File not as expected".

But there is a bug, grouped object that forms the table on 1st page is not shown as expected. And that would be a regression from 6.2 because it looked like a table in 6.1. I set bibisect request for this.

Another problem is that table form on 1st page can be filled in MSO, we can type inside. In LO we cannot, seems it never worked. We can type only on 2nd page.
Comment 5 luigisic 2020-07-28 07:09:27 UTC
Hello,
  sorry for my mistake on reporting the bug.

Even in 2nd page there is two tables:
- The first table (that contain only 1 row) is mistaken for an image and can't typed in.
- The 2nd table can typed in.

Thanks.
Comment 6 Attila Baraksó (NISZ) 2020-07-28 11:12:43 UTC
Bibisected using bibisect-win32-6-1 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=d07fc485d46f431405a3f6a002f951a08c559677
author: Patrick Jaap <patrick.jaap@tu-dresden.de>
committer: Miklos Vajna <vmiklos@collabora.co.uk>
summary: tdf#116486 Consider upper margin in paragraph positioning with flys
Comment 7 Xisco Faulí 2021-03-18 09:01:19 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=c9e5640c8fcad7beb42a66f9bee0252eee9fe323

Closing as duplicate of bug 118693

*** This bug has been marked as a duplicate of bug 118693 ***