Download it now!
Bug 135149 - Image in frame in DOCX not deleted when pressing delete
Summary: Image in frame in DOCX not deleted when pressing delete
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.2
Keywords: bibisected, bisected, regression
: 135097 135732 (view as bug list)
Depends on:
Blocks: Textbox
  Show dependency treegraph
 
Reported: 2020-07-26 12:31 UTC by Telesto
Modified: 2020-12-03 15:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX Example (409.52 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-07-26 12:31 UTC, Telesto
Details
Source ODT (418.77 KB, application/vnd.oasis.opendocument.text)
2020-07-26 12:31 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-26 12:31:18 UTC
Description:
Image in DOCX not deleted when pressing delete 

Steps to Reproduce:
1. Open the attached file
2. Select for example figure 10
3. Press Delete -> image moves up still around

Actual Results:
Image still around after pressing delete

Expected Results:
Should not be so


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in 
4.4.7.2

4.3.7.2 crashes

not in
4.2.7.2
Comment 1 Telesto 2020-07-26 12:31:38 UTC
Created attachment 163552 [details]
DOCX Example
Comment 2 Telesto 2020-07-26 12:31:59 UTC
Created attachment 163553 [details]
Source ODT
Comment 3 Telesto 2020-07-26 12:36:33 UTC
Likely bug 135016

*** This bug has been marked as a duplicate of bug 135016 ***
Comment 4 Xisco Faulí 2020-07-27 10:32:28 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: b68c10a0d0e6f83b6b037da72210033cacb1677b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Aron Budea 2020-08-27 07:56:34 UTC
(In reply to Telesto from comment #0)
> 2. Select for example figure 10
A clarification here, you have to select the whole frame, not just the image here.

Bibisected to the following commit using repo bibisect-44max, it's the same result as for bug 135153 and bug 135383. Adding CC: to Miklos Vajna.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7596e26fd259ce5445212949403e7cd32303b2bd
author		Miklos Vajna <vmiklos@collabora.co.uk>	2014-06-24 17:11:25 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-06-24 17:47:40 +0200

Add SwTextBoxHelper::findShapes
Comment 6 Commit Notification 2020-09-08 07:11:58 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/da4f9b77a6cd39b1ae5babdd476d1575c8b9371c

tdf#135149 sw: fix deleting textbox of as-char shapes

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-09-08 19:35:28 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/821909ee711f7806d899900b739503f20e1879e5

tdf#135149 sw: fix deleting textbox of as-char shapes

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-09-29 15:15:47 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: cd85546a2fbdade42f80fd3b6bd650791db9f32d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 9 Attila Baraksó (NISZ) 2020-11-17 10:30:19 UTC
*** Bug 135097 has been marked as a duplicate of this bug. ***
Comment 10 NISZ LibreOffice Team 2020-12-03 15:50:37 UTC
*** Bug 135732 has been marked as a duplicate of this bug. ***