Download it now!
Bug 135171 - FILEOPEN: DOCX: file exported from LibreOffice takes long long time to open
Summary: FILEOPEN: DOCX: file exported from LibreOffice takes long long time to open
Status: RESOLVED DUPLICATE of bug 135245
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:docx, perf, regression, wantBacktrace
Depends on:
Blocks: DOCX-Opening
  Show dependency treegraph
 
Reported: 2020-07-26 19:53 UTC by Telesto
Modified: 2021-01-21 09:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file DOCX exported with 7.1 (1.45 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-07-26 19:54 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-26 19:53:57 UTC
Description:
FILEOPEN DOCX: Takes long long time

Steps to Reproduce:
1. Open attachment 163583 [details]
2. Save as DOCX
3. File reload -> Start waiting.. 

Actual Results:
2 minutes or more didn't wait

Expected Results:
30 seconds


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-26 19:54:29 UTC
Created attachment 163585 [details]
Example file DOCX exported with 7.1
Comment 2 Telesto 2020-07-26 20:00:12 UTC
Also found in 6.0

not in 5.2.5 (rendering surely not perfect, but does open :-)

even faster in 4.4.7.2 (but probably incomplete)
Comment 3 Telesto 2020-07-26 20:02:34 UTC
A file exported by 5.2.5 opens also fine in 7.1
Comment 4 Xisco Faulí 2020-08-10 16:29:04 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 6ad2f463784a24c566477cdd60ae729651bb8564
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

I killed LibreOffice after 

real	9m12,023s
user	9m5,369s
sys	0m4,111s
Comment 5 Roman Kuznetsov 2020-09-30 17:23:15 UTC
So the problem is with export to DOCX from some LO version? The opening problem is just a consequence from wrong export?
Comment 6 Justin L 2021-01-21 09:39:21 UTC

*** This bug has been marked as a duplicate of bug 135245 ***