Download it now!
Bug 135179 - CRASH after closing sidebar after using Styles Inspector
Summary: CRASH after closing sidebar after using Styles Inspector
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Shivam Kumar Singh
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-07-27 08:38 UTC by Mike Kaganski
Modified: 2020-07-30 09:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-07-27 08:38:31 UTC
In a Writer document, open Styles Inspector, then close sidebar using View->Sidebar. Then click somewhere in a differently formatted text will crash.

Tested with Version: 7.1.0.0.alpha0+ (x64)
Build ID: 545dcd2c743ed40b9adaa2f60692200589b60eb7
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

Caused by SI not restoring the change link when closing (SwWrtShell::SetChgLnk).
Comment 1 Commit Notification 2020-07-28 19:19:59 UTC
Shivam Kumar Singh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3b8c893b487a3ee27bac710da74856225fb72950

tdf#135178 tdf#135179 tdf#134820 Issue in SetChgLnk in Inspector

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Xisco Faulí 2020-07-30 09:19:03 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 231e1e416c039d1f9724962a89cf0573a3db48a2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Shivam Kumar Singh, thanks for fixing this issue!!