Download it now!
Bug 135222 - FILESAVE DOC: layout different (solely image without surrounding text)
Summary: FILESAVE DOC: layout different (solely image without surrounding text)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2020-07-28 11:42 UTC by Telesto
Modified: 2020-09-01 17:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (2.12 MB, application/vnd.oasis.opendocument.text)
2020-07-28 11:42 UTC, Telesto
Details
Comparison before and after RT in LibreOffice 7.1 (240.95 KB, image/png)
2020-07-28 15:22 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-28 11:42:02 UTC
Description:
FILESAVE DOC: layout different (solely image without surrounding text)

Steps to Reproduce:
1. Open the attached file
2. Save As DOC
3. File Reload -> Look at the second page

Actual Results:
Image with frame solely on page 2

Expected Results:
Same or similar to ODT


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
4.4.7.2

not in
4.3.7.2
Comment 1 Telesto 2020-07-28 11:42:18 UTC
Created attachment 163688 [details]
Example file
Comment 2 Xisco Faulí 2020-07-28 15:22:42 UTC
Created attachment 163700 [details]
Comparison before and after RT in LibreOffice 7.1
Comment 3 Xisco Faulí 2020-07-28 15:22:59 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: b33034e7faee2cb8a602ed3342803bf731da8a8b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 raal 2020-08-30 17:14:56 UTC
Please can you retest it? works for me in Version: 7.1.0.0.alpha0+
Build ID: 217122387f6e0ef657b8ba85eae082b448901cec
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 5 Telesto 2020-08-30 18:09:24 UTC
Surprisingly working; didn't expect that
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (nl_NL); UI: en-US
Calc: CL
Comment 6 Xisco Faulí 2020-09-01 17:06:52 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=6457d46967f8dbb41199b750d59edde839f24b5d

@Justin, thanks for fixing this issue!