Download it now!
Bug 135293 - Use a lighter colour for the option checkboxes when the system is using Dark mode (Windows).
Summary: Use a lighter colour for the option checkboxes when the system is using Dark ...
Status: RESOLVED DUPLICATE of bug 118320
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-07-29 20:48 UTC by typingcat
Modified: 2020-08-02 22:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Save, dark mode. (16.61 KB, image/png)
2020-07-29 20:49 UTC, typingcat
Details
KDE using Breeze Dark theme and style (15.25 KB, image/png)
2020-08-02 10:27 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description typingcat 2020-07-29 20:48:13 UTC
Description:
Windows 10 has dark mode (Settings -> Personalisation -> Colours -> Choose your colour". However, it seems that Writer's save file dialogue uses blue colour for the checkboxes. First of all, using blue colour for checkboxes is weird on Windows, unless it is a clickable hyperlink, which it is not. And it is barely readable when using the Dark mode on a low brightness monitor.

Steps to Reproduce:
1. Turn on dark mode (Settings -> Personalisation -> Colours -> Choose your colour"
2. Save (Ctrl+S)
3.

Actual Results:
Checkbox text too dark to read.

Expected Results:
Lighter colour when the system is using Dark mode.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
See the screenshot.
Comment 1 typingcat 2020-07-29 20:49:52 UTC
Created attachment 163751 [details]
Save, dark mode.

Screenshot.
Comment 2 Heiko Tietze 2020-08-02 10:27:20 UTC
Created attachment 163877 [details]
KDE using Breeze Dark theme and style

Doesn't it pick up what your theme has defined? Works at least for me.
Comment 3 typingcat 2020-08-02 21:15:33 UTC
(In reply to Heiko Tietze from comment #2)
> Created attachment 163877 [details]
> KDE using Breeze Dark theme and style
> 
> Doesn't it pick up what your theme has defined? Works at least for me.

That is Linux; this entry is for Windows. I tested it on Ubuntu Gnome (dark theme) and the checkbox texts were white as your KDE, but on Windows, it shows blue text on a dark background, making it difficult to read.
Comment 4 V Stuart Foote 2020-08-02 22:50:28 UTC
Invalid, no support for Windows Dark mode UWP themeing has been implemented. 

See bug 118320

*** This bug has been marked as a duplicate of bug 118320 ***