Bug 135301 - Select All cut leaves bullet behind of on top of the page
Summary: Select All cut leaves bullet behind of on top of the page
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists Selection
  Show dependency treegraph
 
Reported: 2020-07-30 09:37 UTC by Telesto
Modified: 2021-05-13 10:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-30 09:37:03 UTC
Description:
Select All cut leaves bullet behind of on top of the page

Steps to Reproduce:
1. Open attachment 163749 [details]
2. CTRL+A
3. CTRL+X or Delete/Backspace

Actual Results:
Bulleted is outside they selection

Expected Results:
I assume it should be in


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); GI: nl-NL
Calc: CL
Comment 1 Telesto 2020-07-30 09:39:18 UTC
@Michael,
Would love the insight of the developer here. As this is the behavior since the start. Bug 135292 is in fact the same thing only a consternation
Comment 2 Dieter 2021-03-01 15:15:09 UTC
I confirm it with

Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL


Aditional obeservations
If you paste the list, first bullet is part of the list. So it's clearly a bug.
Comment 3 Justin L 2021-05-01 11:22:52 UTC
The bullet is a paragraph property. Since cutting can't leave a document without any paragraph, the paragraph remains with it's properties. 

That is no different than the paragraph retaining bold, underline, fontsize etc.
Comment 4 Dieter 2021-05-01 12:07:15 UTC
(In reply to Justin L from comment #3)
> The bullet is a paragraph property. Since cutting can't leave a document
> without any paragraph, the paragraph remains with it's properties. 
> 
> That is no different than the paragraph retaining bold, underline, fontsize
> etc.

I disagree, because I think, you're not right. I agree with you, that there can't be a document without a paragraph. But it is always the last paragraph that remains after cutting all. If you enable formatting marks you can see, that formatting mark from last paragraph isn't selected. And if you change font size of the last paragraph you can easily see, that font size of the last paragraph remains after cutting all.
=> Back to NEW
Comment 5 Justin L 2021-05-05 11:43:31 UTC
(In reply to Dieter from comment #4)
> But it is always the last paragraph that remains after cutting all.
That doesn't seem to be true. Try setting the first paragraph to "Title" and the last paragraph to "Appendix".  When you delete all, you will have Title as the paragraph style. (Font size etc are character properties, and those indeed do seem to come from the last "run"/paragraph.)
Comment 6 Dieter 2021-05-13 10:10:00 UTC
(In reply to Justin L from comment #5)
> (In reply to Dieter from comment #4)
> > But it is always the last paragraph that remains after cutting all.
> That doesn't seem to be true. Try setting the first paragraph to "Title" and
> the last paragraph to "Appendix".  When you delete all, you will have Title
> as the paragraph style. (Font size etc are character properties, and those
> indeed do seem to come from the last "run"/paragraph.)

Soryy, you're right. Don't know, why I had a different result before. Couldn't reproduce it now.
=> RESOLVED NOTABUG