Download it now!
Bug 135312 - Sequential name for objects in Draw and other apps (and total count in properties)
Summary: Sequential name for objects in Draw and other apps (and total count in proper...
Status: RESOLVED DUPLICATE of bug 90244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-30 11:47 UTC by Leandro Martín Drudi
Modified: 2020-08-04 12:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
About 14 million objects that cannot be renamed from the side panel. (11.83 KB, image/png)
2020-07-30 12:00 UTC, Leandro Martín Drudi
Details
An example from Corel, with objects renamed (16.99 KB, image/png)
2020-07-30 12:01 UTC, Leandro Martín Drudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Martín Drudi 2020-07-30 11:47:48 UTC
Description:
It is very useful to be able to know the amount of objects and even the amount of X objects.
Currently the numbering is not useful as it only counts the groups and then the objects within that group.
What I propose is to number the layers, groups and objects separately, but within the same name.


Steps to Reproduce:
1. Insert several shapes.
2. Group some of them together.
3. Stack some groups and some shapes.
3. Open the Navigator.

Actual Results:
Página 1
    Forma 1
    Forma 2
         Forma 1
         Forma 2
   Forma 3
         Forma 1

Expected Results:
Layer 1-Group1
   Shape 1
   Shape 2
   Shape 3
Layer 2-Shape 4
Layer 5-Image 1
Layer 6-Group2
   Shape 5


Reproducible: Always


User Profile Reset: No



Additional Info:
In the file properties it would be good to find an overview of the objects that make up the file:
Shapes: 45
Pictures: 5
Pages: 2
Total: 52
Comment 1 Leandro Martín Drudi 2020-07-30 12:00:47 UTC
Created attachment 163767 [details]
About 14 million objects that cannot be renamed from the side panel.

Currently, objects cannot be renamed except from the individual object properties. It would be very useful to be able to do this from the side panel and/or browser. In the era of immediacy, this makes LibO a long way behind.
Comment 2 Leandro Martín Drudi 2020-07-30 12:01:55 UTC
Created attachment 163768 [details]
An example from Corel, with objects renamed

In this case the objects have their own name, but the group counts the number of objects in it.
Comment 3 Heiko Tietze 2020-08-03 14:07:07 UTC
If you select all, the number of objects is shown in the statusbar (like it's done for words/characters in Writer). Is this sufficient?

Suggest to rename the ticket to something like "Show object numbers in Draw" as the number on the name Shape1...ShapeX never was meant to count.
Comment 4 Leandro Martín Drudi 2020-08-03 17:46:11 UTC
I return to the question: is that enough for you? Do you really think that it is the solution to a problem that must be solved to make the software more efficient and complete? If you select a group, only 1 object appears. Imagine having 600 groups with 60 objects each, do you think you have to ungroup them all to know how many objects you have?
Don't you think it's time to do something that serves the user instead of filling a gap are hundreds of clicks to get something that should / could be always on screen?
I used Calc to get the amount of objects in a pattern that I did: 14,348,907 was the result. They are grouped by 3 objects, which makes a total of 4,782,969 groups. According to your solution I should ungroup that amount just to know how many objects I have.
Also, renaming them is as torturous as it is inefficient: I have to enter them ONE BY ONE and rename them from the properties. If it was done with a simple double click in the browser or with a right click and then Rename would be much faster.
Every time I report something and they respond with what I consider an excuse not to add/improve/prove features that raise the level of LibreOffice they take me far away. I started replacing MSOffice with LibreOffice practically since its release. Today, due to its inefficiency, I only use Writer and I am planning to stop using it definitively in a short term.
I'll just say this.
Comment 5 V Stuart Foote 2020-08-04 03:01:13 UTC
There is a lot of misinformation to be unpacked here compared to how LibreOffice actually deals wtih Draw shapes, Layers and Objects as a functional limitation of our native ODF Drawing XML spec.

Handling of unnamed/autonamed Draw Shapes vs user named Draw shapes and other Draw objects, and their grouping via Draw layers.

This is a duplicate of bug 90244 for the Navigator in Draw with UX work-up in
https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-support-object-handling-in-libreoffice-draw/

*** This bug has been marked as a duplicate of bug 90244 ***
Comment 6 Heiko Tietze 2020-08-04 07:27:54 UTC
(In reply to V Stuart Foote from comment #5)

> *** This bug has been marked as a duplicate of bug 90244 ***

What a pity to drop a potentially fine enhancement, namely improvement to the object count in Draw's statusbar, as a duplicate of better interaction. My recommendation would have been to show the total number of objects in the statusbar and to have some kind of dialog on click with a more detailed statistics.

But since Leandro is unhappy with this solution, moved to MSO, and is apparently the only one who needs this feature it doesn't matter anyway. 

@Leandro: "Every time I report something and they respond with what I consider an excuse not to add/improve/prove features..." is discouraging. We try to find a solution for your workflow that works for many other users and scenarios too, is easy to use, ideally fits into existing pattern, and has low effort in implementation. If you want your idea implemented, please consult a professional supporter https://www.libreoffice.org/get-help/professional-support/.
Comment 7 Leandro Martín Drudi 2020-08-04 11:38:51 UTC
(In reply to V Stuart Foote from comment #5)
> There is a lot of misinformation to be unpacked here compared to how
> LibreOffice actually deals wtih Draw shapes, Layers and Objects as a
> functional limitation of our native ODF Drawing XML spec.
> 
> Handling of unnamed/autonamed Draw Shapes vs user named Draw shapes and
> other Draw objects, and their grouping via Draw layers.
> 
> This is a duplicate of bug 90244 for the Navigator in Draw with UX work-up in
> https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-
> support-object-handling-in-libreoffice-draw/
> 
> *** This bug has been marked as a duplicate of bug 90244 ***

Duplicate of a 2015 report!
The report he quotes is from 2015-03-26 06:12:55 UTC. It has been 5 years, 4 months, 1 week and 2 days (or 1958 days) and they have done nothing with something that is being asked for BECAUSE IT IS NEEDED. And if they don't think it's needed, it's something that adds up to the race for modernity.
We are in the century where immediacy is extremely necessary in order not to lose competitiveness. I can't get an answer in 3 days about something I need now. However, users have been waiting for an answer for more than 5 years.
This inefficiency is going to cost them dearly in the future. Otherwise, see OpenOffice. It is going to die because it does not advance at the same time as the market. Linux is advancing, but it is very behind in many aspects and that's why it has a very reduced market share.
LibreOffice is doomed to die if the policy is not changed and improved according to how the rest advances.
This cannot be left in a chain of emails discussing if it can, if it should, if it is a lot of work, if it can be achieved in another way.
I feel ridiculous planting this. They love LibreOffice so much, they're suffocating it.
Comment 8 V Stuart Foote 2020-08-04 12:23:02 UTC
(In reply to Heiko Tietze from comment #6)
> > *** This bug has been marked as a duplicate of bug 90244 ***
> 
> What a pity to drop a potentially fine enhancement, namely improvement to
> the object count in Draw's statusbar, as a duplicate of better interaction.
> My recommendation would have been to show the total number of objects in the
> statusbar and to have some kind of dialog on click with a more detailed
> statistics.

Sure the object count(s) could/should be included on Status Bar when the Draw module gets the work needed to its Navigator deck and its Layer tabs--doing it separately would make little difference as the framework to actually work with the individual Draw shapes, Objects and Layers efficiently is missing. Best to revisit the UX-Design linked to append the indicators on the Status Bar.

That does nothing for request of OP, which can only be addressed with major refactoring of the sd layer and object framework and extension of ODF.