Bug 135326 - FONT EFFECT: Not possible to enable "Hidden" option with ~h
Summary: FONT EFFECT: Not possible to enable "Hidden" option with ~h
Status: RESOLVED DUPLICATE of bug 127611
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Effects
  Show dependency treegraph
 
Reported: 2020-07-30 18:04 UTC by TorrAB
Modified: 2020-12-27 07:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2020-07-30 18:04:30 UTC
Description:
	In any Writer file, select a char, then Format>character>FontEffects; hit ~h: ‘Hidden’ is framed but the box is not checked; OK is highlighted; hit Enter; the character is not hidden.
	If you check the box by clicking with the mouse, it works: character is marked hidden (dot-underlined), but (Is that another bug?) remains visible even if Tools>Options>Writer>View HiddenText is off.


Steps to Reproduce:
1.see above
2.
3.

Actual Results:
~h does not activate the hiding

Expected Results:
~h should check the box 


Reproducible: Always


User Profile Reset: No



Additional Info:
none
Comment 1 Dieter 2020-08-04 10:47:15 UTC
(In reply to TorrAB from comment #0)
> 	If you check the box by clicking with the mouse, it works: character is
> marked hidden (dot-underlined), but (Is that another bug?) remains visible
> even if Tools>Options>Writer>View HiddenText is off.

I can't confirm this. Please report it in a new bug report. Thanks
Comment 2 Dieter 2020-08-04 10:50:32 UTC
(In reply to TorrAB from comment #0)
> Description:
> 	In any Writer file, select a char, then Format>character>FontEffects; hit
> ~h: ‘Hidden’ is framed but the box is not checked; OK is highlighted; hit
> Enter; the character is not hidden.

I confirm that behaviour with

Version: 7.0.0.0.beta2 (x64)
Build ID: 1c213561a365b5666167321de68c9977500c9612
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 3 NISZ LibreOffice Team 2020-12-07 08:13:19 UTC
(In reply to TorrAB from comment #0)
> Description:
> 	In any Writer file, select a char, then Format>character>FontEffects; hit
> ~h: ‘Hidden’ is framed but the box is not checked; OK is highlighted; hit
> Enter; the character is not hidden.

This is because the shortcut letter of Hidden is H, same as the Help button at the dialogs bottom.
We need to change that to "d" which is not used in this dialog.

> 	If you check the box by clicking with the mouse, it works: character is
> marked hidden (dot-underlined), but (Is that another bug?) remains visible
> even if Tools>Options>Writer>View HiddenText is off.

Hidden characters display can be toggled under Options - Writer - Formatting Aids - Hidden characters.

Somewhat confusing indeed.
Comment 4 Ming Hua 2020-12-07 09:12:21 UTC
Isn't this just a duplicate of bug 127611 (by the same reporter, even), or am I missing something?
Comment 5 Gabor Kelemen (allotropia) 2020-12-27 07:12:11 UTC
(In reply to Ming Hua from comment #4)
> Isn't this just a duplicate of bug 127611 (by the same reporter, even), or
> am I missing something?

Indeed a duplicate!

*** This bug has been marked as a duplicate of bug 127611 ***