Download it now!
Bug 135337 - The «Tab» key and Alt-Underlined key shortcuts do not work as expected in the «Insert > Hyperlink» dialogue
Summary: The «Tab» key and Alt-Underlined key shortcuts do not work as expected in the...
Status: RESOLVED DUPLICATE of bug 131970
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Shortcuts-Accelerators Hyperlink-Dialog
  Show dependency treegraph
 
Reported: 2020-07-31 09:51 UTC by Sergey Nemna
Modified: 2020-12-26 21:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The «Hyperlink» dialogue (18.36 KB, image/png)
2020-07-31 09:53 UTC, Sergey Nemna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Nemna 2020-07-31 09:51:46 UTC
Description:
The described bug implies seriously limitation on what can be done with keyboard in this dialogue window.


Steps to Reproduce:
1) Launch Calc.
2) Hit Ctrl-K.
3) Hit Tab.
4) Hit Alt-X.

Actual Results:
The button «Help» gets focus (after the 3rd step).

Nothing happens (after the 4th step).

Expected Results:
The next field «Frame» gets focus (after the 3rd step).

The field «Text» gets focus (after the 4th step).


Reproducible: Always


User Profile Reset: No



Additional Info:
As soon as any of the buttons of the bottom button row gets focus, there is no way  to take focus to any GUI element but the buttons no matter how many times Tab is hit (user is forced to use mouse). The Alt-Underlined keys shortcuts do not work either (Alt-X is just an example).

Verified on:
1) LO 6.4.4.2 (x32) Windows 7 x32 SP1
2) LO 6.4.4.2 (x32) Lubuntu 20.04
Comment 1 Sergey Nemna 2020-07-31 09:53:27 UTC
Created attachment 163801 [details]
The «Hyperlink» dialogue
Comment 2 Roman Kuznetsov 2020-08-27 20:08:36 UTC
confirm in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 15988fe00c4f49ae32ab2d5cf3c16495ab6e1d59
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 3 Ming Hua 2020-11-24 02:46:52 UTC
*** Bug 133718 has been marked as a duplicate of this bug. ***
Comment 4 Ming Hua 2020-11-24 18:17:40 UTC
This is a regression.

Working in 6.3.5:
Version: 6.3.5.2 (x64)
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

... but not in 6.4.7 (i.e. can reproduce the bug):
Version: 6.4.7.2 (x64)
Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

Bibisect requested.  (I suspect one of Caolán's UI weld efforts :-P)
Comment 5 Gabor Kelemen 2020-12-26 21:17:21 UTC
This seems to have been fixed in 7.1 since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=de34c45a8ac1f7f1264d8ef649e7b7ee5ab1d2ec

author	Caolán McNamara <caolanm@redhat.com>	2020-11-12 14:46:03 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-11-13 14:33:30 +0100

tdf#131970 enable tab-cycling between VerticalTabControl members

*** This bug has been marked as a duplicate of bug 131970 ***