Download it now!
Bug 135339 - auto-update Table of Contents (TOC) whenever headlines are changed / addded / removed
Summary: auto-update Table of Contents (TOC) whenever headlines are changed / addded /...
Status: RESOLVED DUPLICATE of bug 44448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-31 10:51 UTC by steve -_-
Modified: 2020-08-02 15:13 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steve -_- 2020-07-31 10:51:19 UTC
Description:
--

Steps to Reproduce:
1. have writer document 
2. change / add / remove headline or TOC relevant element

Actual Results:
TOC not updated. Currently LO required the user to manually update the TOC via right-click on TOC > Update Index

Expected Results:
It would be more intuitive and convenient to automatically have LO update the TOC.


Reproducible: Always


User Profile Reset: No



Additional Info:
Obviously this raises performance needs. Maybe the documents I tested with were too small to cause any noticeable performance implications when updating TOC.

Also some logic would be required to not have LO update the TOC for every single keyboard press that is done. So whenever a TOC relevant element is changed, that could trigger a 30 second delay to update the TOC.

If this is a performance concern at all, a setting option could be added to disable / enable. But adding more settings isn't great.
Comment 1 Timur 2020-08-02 15:13:57 UTC

*** This bug has been marked as a duplicate of bug 44448 ***