Bug 135344 - Styles inspector scrollbar issues
Summary: Styles inspector scrollbar issues
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-07-31 13:05 UTC by Thomas Lendo
Modified: 2020-08-08 22:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Missing horizontal scrollbar although the panel content is wider than the sidebar panel frame (45.13 KB, image/png)
2020-07-31 17:35 UTC, Thomas Lendo
Details
video - not reproducing (273.31 KB, video/mp4)
2020-07-31 18:43 UTC, BogdanB
Details
Screencast with 2 vertical scrollbars, Ubuntu 18.04 an daily master build 7.1.0.0 (918.24 KB, video/mp4)
2020-08-01 14:12 UTC, Thomas Lendo
Details
Screencast with Ubuntu 18.04 with build from 2020-07-30 (1.91 MB, video/mp4)
2020-08-02 08:28 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2020-07-31 13:05:09 UTC
When the properties columns are wider than the sidebar panel width, then a horizontal scrollbar should be visible in the bottom to give the user the chance to move the view.
Comment 1 Heiko Tietze 2020-07-31 15:03:19 UTC
OS/DE? Commented on a patch that we should optimize the columns so a scrollbar is not necessary. Meaning I see a scrollbar using KDE.
Comment 2 BogdanB 2020-07-31 15:27:28 UTC
I have the latest version
Version: 7.1.0.0.alpha0+
Build ID: 231e1e416c039d1f9724962a89cf0573a3db48a2
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

And I have in the bottom the scrollbar when properties on the right are open.
Comment 3 BogdanB 2020-07-31 15:27:34 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2020-07-31 17:31:42 UTC
No horizontal scrollbar with

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-07-29_04:49:51
Calc: threaded

with the daily master build downloaded a few hours ago today

OS: Ubuntu 18.04
Comment 5 Thomas Lendo 2020-07-31 17:35:53 UTC
Created attachment 163827 [details]
Missing horizontal scrollbar although the panel content is wider than the sidebar panel frame
Comment 6 BogdanB 2020-07-31 18:37:56 UTC
Can you create a short screencast?
Comment 7 BogdanB 2020-07-31 18:43:31 UTC
Created attachment 163830 [details]
video - not reproducing

I have that scroll, see video
Comment 8 Thomas Lendo 2020-08-01 14:11:22 UTC
Ah, during marking the screencast I noticed that not the horizontal scrollbar is missing but that there can be more than one vertical scrollbar.

When opening the node of Default Paragraph Style, then a new scrollbar appears.

So the user has to use several scrollbars in one direction.

Is this intended or due to programming circumstances?
Comment 9 Thomas Lendo 2020-08-01 14:12:40 UTC
Created attachment 163845 [details]
Screencast with 2 vertical scrollbars, Ubuntu 18.04 an daily master build 7.1.0.0
Comment 10 Shivam Kumar Singh 2020-08-01 19:31:38 UTC
I do have the horizontal bar :-
https://imgur.com/a/6jfZAbp
Comment 11 Shivam Kumar Singh 2020-08-01 19:37:28 UTC
(In reply to Thomas Lendo from comment #9)
> Created attachment 163845 [details]
> Screencast with 2 vertical scrollbars, Ubuntu 18.04 an daily master build
> 7.1.0.0

Cannot reproduce this in 
Version: 7.1.0.0.alpha0+
Build ID: 51735e6946dca0528a4b78d06ef43bd84c38e5e1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
Calc: threaded

This issue must be resolved in https://gerrit.libreoffice.org/c/core/+/99774.
Could you please check if your master is updated with this patch ?
Comment 12 Thomas Lendo 2020-08-02 08:28:28 UTC
Created attachment 163867 [details]
Screencast with Ubuntu 18.04 with build from 2020-07-30

Hi Shivam, I've made a new screencast with the daily master build from a few minutes ago.

Weird, that 1) I don't see a vertical scrollbar although the item length is longer than the sidebar width and 2) I can't scroll down to the last item in the list of the direct formatting settings.


Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-07-30_20:15:28
Calc: threaded
Comment 13 Heiko Tietze 2020-08-02 09:30:23 UTC
Caolan, you provided a patch recently to maximize the view [1]. However, according to comment 9 it looks like the view is one entry larger, so the horizontal scrollbar is hidden. In fact, the tree is still 2/3 of the deck height and scrolls the content by itself, additionally to the deck scrolling. I'm pretty sure your patch did solve the issue. Any idea what's wrong here?

Version: 7.1.0.0.alpha0+
Build ID: 2b947aeedcbc585df73ed642729a6c84a4bbbed3
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded

[1] bug 134831, https://gerrit.libreoffice.org/c/core/+/99774, latest patch on https://opengrok.libreoffice.org/history/core/svx/uiconfig/ui/inspectortextpanel.ui
Comment 14 Heiko Tietze 2020-08-02 10:17:51 UTC
The initial view is maximized but the tree doesn't respond on resizing.
Comment 15 Shivam Kumar Singh 2020-08-03 14:41:11 UTC
(In reply to Heiko Tietze from comment #13)
> Caolan, you provided a patch recently to maximize the view [1]. However,
> according to comment 9 it looks like the view is one entry larger, so the
> horizontal scrollbar is hidden. In fact, the tree is still 2/3 of the deck
> height and scrolls the content by itself, additionally to the deck
> scrolling. I'm pretty sure your patch did solve the issue. Any idea what's
> wrong here?

Heiko does this occur with you too ?
Caolan's patch did resolve all the sizing issues for me.

Hi Thomas, I cannot find you on gerrit, could you please check if this patch solves your issues?
https://gerrit.libreoffice.org/c/core/+/100010
Comment 16 Heiko Tietze 2020-08-03 17:15:57 UTC
(In reply to Shivam Kumar Singh from comment #15)
> Heiko does this occur with you too ?

Yes, see comment 13 and 14.
Comment 17 Commit Notification 2020-08-05 15:07:26 UTC
Shivam Kumar Singh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b6576ce2321f68e4e2c7399f3c2fdf934df43d1e

tdf#135344 Resolved Inspector scroll bar issues

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Thomas Lendo 2020-08-08 22:00:02 UTC
Looks good in

Version: 7.1.0.0.alpha0+
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: de-AT (de_AT.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-05_04:03:50
Calc: CL

Thanks!