Bug 135358 - Export PDF fails if existing pdf is still open: LO should check first and warn user
Summary: Export PDF fails if existing pdf is still open: LO should check first and war...
Status: RESOLVED DUPLICATE of bug 53530
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-01 11:37 UTC by R. Green
Modified: 2020-08-01 18:00 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description R. Green 2020-08-01 11:37:38 UTC
Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

I have lost count of the number of times I have attempted to export Writer files as PDFs—only to see the message, "Error saving the document." The reason for this is very simple: a pdf of the same name is already open. It is a very easy trap to fall into repeatedly—no matter how experienced.

SUGGESTION: Before going ahead with the PDF export operation, LibreOffice should check whether a PDF document of the same name is OPEN at that location and, if so, warn the user to close it first.
Comment 1 Telesto 2020-08-01 18:00:56 UTC
Adding this to bug 53530. As more or less about the same thing.. A check of file in use might be practical indeed

*** This bug has been marked as a duplicate of bug 53530 ***