Bug 135398 - UI: save-as dialog fails to populate list of dirs/files
Summary: UI: save-as dialog fails to populate list of dirs/files
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, corruptProfile, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2020-08-02 22:49 UTC by Terrence Enger
Modified: 2020-08-03 17:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bibisect-linux-64-6.4, tail or terminal output (2.79 KB, text/plain)
2020-08-02 22:49 UTC, Terrence Enger
Details
I can't reproduce it in LibreOffice 7.1 (70.96 KB, image/png)
2020-08-03 15:16 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2020-08-02 22:49:07 UTC
Created attachment 163889 [details]
bibisect-linux-64-6.4, tail or terminal output

I first noticed this in a local build of commit 51735e69 (2020-07-30)
on debian-buster.  The bibisect result is from bibisect-linux-64-6.4
on the same system, using (a copy of) the user profile from my local
build.

Note that I see the problem only with SAL_USE_VCLPLUGIN=gtk3 and only
when using LibreOfficeDev dialogs; system dialogs do not have the
problem.

I see the problem with Save-As from Calc and Writer; I have not tried
other applications.


STR

(0) Make your LibreOffice use LibreOffice dialogs:

      - Menu Tools > Options... . Program presents dialog "Options -
        ... - User Data".

      - In left pane, click General.  Program presents dialog
        "Options - ... - General"

      - Ensure that "Open/Save Dialogs" > "Use LibreOfficeDev dialogs"
        is checked.  Save this change if necessary.

(1) Start Calc.  LibreOffice presents Calc window "Untitled 1"

(2) Menu options File > "Save As...". LibreOffice presents dialog
    "Save as".  The directory named is your home Documents directory.

        good : The middle pane shows the directories and files in your
               home Documents directory.

        bad  : The directory name is selected (i.e., reverse-image),
               the list is empty, and the first (blank) item in the
               list is selected.

(3) Change directory name to /tmp and press <Enter>.

        good : The middle pane shows the directories and files in /tmp/.

        bad : The middle pane is empty , and the first (blank) item in
              the list is selected.


The bibisect shows:

          commit    s-h       date
    good  4b4ebe2d  93a641d2  2019-10-29 12:20:10
    bad   5d1baf3f  09e3d45c  2019-10-29 12:58:47

The commit message for 09e3d45c starts:

    commit 09e3d45cdc5c739e5246388a83ccfc6d76bf66e9
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Mon Oct 21 14:20:12 2019 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Tue Oct 29 13:58:47 2019 +0100

        weld fpicker cluster


I am setting priority minor because (*) the problem only appears in
specific conditions (*)the problem is grossly obvious, (*) the user
may be able to complete the save without the list, and (*) an easy
(albeit not obvious) workaround is to use system dialogs for
Open/save.

I am setting keywords corruptProfile, bibisected, bisected,
regression, and I am setting blocks: GTK3.

Any advice about how to localize the problem within the user profile
would be welcome.
Comment 1 Xisco Faulí 2020-08-03 15:16:57 UTC
Created attachment 163904 [details]
I can't reproduce it in LibreOffice 7.1
Comment 2 Xisco Faulí 2020-08-03 15:17:52 UTC
I can't reproduce it in

Version: 7.1.0.0.alpha0+
Build ID: 32090b018d9ff81659a4c9ed41c64109ebebe4fc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, do you reproduce it on your end since the bisection points to 09e3d45cdc5c739e5246388a83ccfc6d76bf66e9 "weld fpicker cluster"
Comment 3 Terrence Enger 2020-08-03 16:15:43 UTC
(In reply to Xisco Faulí from comment #2)
> I can't reproduce it in
...

Should I attach the bad user profile?  It is about 4MB; I do not know
how well it would compress.
Comment 4 Xisco Faulí 2020-08-03 16:19:05 UTC
(In reply to Terrence Enger from comment #3)
> (In reply to Xisco Faulí from comment #2)
> > I can't reproduce it in
> ...
> 
> Should I attach the bad user profile?  It is about 4MB; I do not know
> how well it would compress.

mmm, so it's happening with a bad user profile only ? Unless we have the steps to recreate the bad user profile from a good user profile, I would not consider this an issue.
Comment 5 Terrence Enger 2020-08-03 17:24:46 UTC
(In reply to Xisco Faulí from comment #4)
> 
> mmm, so it's happening with a bad user profile only ? Unless we have the
> steps to recreate the bad user profile from a good user profile, I would not
> consider this an issue.

Would "abuse it in every way suggested by any bug report I poke into"
pass muster for the steps to recreate?  No?  I thought not.

I am setting status RESOLVED INSUFFICIENTDATA.

Thank you, Xisco, for your help.