Download it now!
Bug 135409 - Setting a page style doesn't convert they page in question but the next (if there is one present)
Summary: Setting a page style doesn't convert they page in question but the next (if t...
Status: RESOLVED DUPLICATE of bug 134395
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-08-03 10:08 UTC by Telesto
Modified: 2020-08-04 09:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-03 10:08:09 UTC
Description:
Setting a page style doesn't convert they page in question but the next (if there is one present)

Steps to Reproduce:
1. Open Writer
2. CTRL+ENTER
3. Format -> Paragraph -> Text flow -> With Page style & set it to Landscape
4. Press OK
5. Press CTRL+Enter twice (adding 2 empty pages) So 3 Landscape
6. Place cursor on page 3
7. Format -> Paragraph -> Text flow -> With Page style & set it to Default 
8. Press OK (next page changes, not to current page.. not sure if this proper.. but not point here)

Screencast: attachment 163895 [details] (which contains this behavior (and goes on to demonstrate)bug 135408)

Actual Results:
Next page gets formatting

Expected Results:
Starting at the underlying page


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in
Version: 6.2.0.0.alpha0+
Build ID: 401cba4c20fbc930f034168872642428d7459218
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL

not in
6.0
Comment 1 Telesto 2020-08-03 10:09:04 UTC
Another one you might be interested in (likely the same root cause as they colored page issue)
Comment 2 Telesto 2020-08-03 10:11:02 UTC
@Heiko
Adding you to CC based on they e-mail conversation :-)
Comment 3 Heiko Tietze 2020-08-03 13:57:48 UTC
See also bug 134439 and bug 134440. Making it a duplicate of bug 134395, which discuss the same topic, and should solved per bug 128616.

*** This bug has been marked as a duplicate of bug 134395 ***
Comment 4 Telesto 2020-08-03 19:34:17 UTC
(In reply to Heiko Tietze from comment #3)
> See also bug 134439 and bug 134440. Making it a duplicate of bug 134395,
> which discuss the same topic, and should solved per bug 128616.
> 
> *** This bug has been marked as a duplicate of bug 134395 ***

You're aware this is a regression ? So 4.4.7.2 - 6.1 having a different behavior?
Comment 5 Heiko Tietze 2020-08-04 08:20:27 UTC
The topic is extensively discussed in the mentioned tickets. Please comment there. Not every fix is a regression IMHO.
Comment 6 Telesto 2020-08-04 09:33:59 UTC
(In reply to Heiko Tietze from comment #5)
> The topic is extensively discussed in the mentioned tickets. Please comment
> there. Not every fix is a regression IMHO.

However, show you see a opportunity to change to something different, while simply broken. Bug 128616 is more an ENHANCEMENT. While there is a commit changing the whole logic; started the whole mess (this and see also's). 

So first they logic must be restored, secondly the ENHANCEMENT implemented :-). Third I start complaining about the ENHANCEMENT not matching expectations. So we start discussing it again etc etc etc. :P