Download it now!
Bug 135412 - CRASH: Undoing paste of section with flys
Summary: CRASH: Undoing paste of section with flys
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:6.4.7
Keywords: bibisected, bisected, regression
: 133917 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-03 11:17 UTC by Xisco Faulí
Modified: 2020-11-05 15:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-08-03 11:17:16 UTC
Steps to reproduce:
1. Open attachment 132837 [details] from bug 107428
2. Select All
3. Cut
4. Paste -> The text is gone
5. Undo

-> Crash

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 32090b018d9ff81659a4c9ed41c64109ebebe4fc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-08-03 11:18:16 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2d89b9929e85bede4c72684a12e7508751875f0e

author	Michael Stahl <Michael.Stahl@cib.de>	2020-06-15 13:11:29 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-06-15 15:58:59 +0200
commit	2d89b9929e85bede4c72684a12e7508751875f0e (patch)
tree	fcfa0397afabff393ed3c4c09fd4c5119c289cbe
parent	786d0b9abf76b2f84d333e18c902a374ab3b3090 (diff)
tdf#133957 sw: SelectAll should select fly in empty section

Bisected with: bibisect-linux64-7.1

Adding Cc: to Michael Stahl
Comment 2 Xisco Faulí 2020-08-03 11:22:50 UTC
Same issue reproduced with attachment 131428 [details] from bug 106153
Comment 3 Xisco Faulí 2020-08-03 11:42:35 UTC
attachment 101747 [details] from bug 80526 is also affected by this issue
Comment 4 Commit Notification 2020-08-19 17:04:40 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/10ae7ba661dff57a7d08174792565ec5e33fae9b

tdf#135412 tdf#135888 sw: fix copying of linked text-boxes

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Stahl (CIB) 2020-08-19 17:13:43 UTC
fixed on master
Comment 6 Commit Notification 2020-08-20 00:49:07 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/9ae30972319a046d0b8176e3f0bc85f8ae976c93

tdf#135412 tdf#135888 sw: fix copying of linked text-boxes

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-08-20 12:15:32 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/8934e31f53274a5e288340c9f756aac5f931eba4

tdf#135412 tdf#135888 sw: fix copying of linked text-boxes

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-09-01 11:17:00 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0fc96ac585520884e3509d574d162ffdae7698c9

tdf#135412: sw_uiwriter: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Kevin Suo 2020-11-05 15:02:33 UTC
*** Bug 133917 has been marked as a duplicate of this bug. ***