Bug 135480 - Saving RTF to PDF does NOT seem to work in 7.0.0 macOS Catalina
Summary: Saving RTF to PDF does NOT seem to work in 7.0.0 macOS Catalina
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist PDF-Export
  Show dependency treegraph
 
Reported: 2020-08-05 21:48 UTC by Nik Finney
Modified: 2021-08-13 10:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nik Finney 2020-08-05 21:48:12 UTC
Description:
Just Upgraded from LO 6.4.5 to 7.0.0.  NOW, when Exporting an RTF to a PDF, seems to start the process, but NEVER asks where to put the NEW Doc.  Does NOT put it where I have previously saved my PDF's.  Search function in Apple Catalina comes up with the OLD PDF.  Mystified.  Going to re-install the 6.4.5 version.

Using Hyperlinked RTF to create Hyperlinked PDF documents ( Useable in Apple Books)

Steps to Reproduce:
1.Open an RTF document
2.Select EXPORT TO PDF
3.Continue

Actual Results:
Process seems to be Working. But NO request as to where to save the NEW Doc.

Expected Results:
NOTHING


Reproducible: Always


User Profile Reset: No



Additional Info:
Ask where to save the NEW File

DUH!!! The NEXT question should have been asked First.  ALSO, ALL of the subsequent Questions should have been offered before I GOT THIS FAR!!!!! I'm NOT going back NOW to go through this process AGAIN.

CAN'T even keep a Copy of this PROTRACTED Bug Report.....
Comment 1 Telesto 2020-08-06 07:34:36 UTC
Likely bug 128233
Comment 2 Roman Kuznetsov 2021-01-31 13:18:00 UTC
no repro in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5346b2556348477dcec371913d5924c6badfa2c7
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded
Comment 3 steve 2021-08-13 10:00:56 UTC
No repro

1. Open rtf with LO
2a. File > Export > PDF shows macOS file save dialog including location selection
2b. File > Export as... > Export as PDF > Export: same

Version: 7.2.0.2 / LibreOffice Community
Build ID: 614be4f5c67816389257027dc5e56c801a547089
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

Setting to worksforme. @Nik if this is persisting for you with LO 7.2.0.2 or later please reopen.