Download it now!
Bug 135498 - UI: Sidebar panel resizing is inconsistent
Summary: UI: Sidebar panel resizing is inconsistent
Status: RESOLVED DUPLICATE of bug 90374
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2020-08-06 12:14 UTC by Telesto
Modified: 2020-08-06 15:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (1.08 MB, video/mp4)
2020-08-06 12:15 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-06 12:14:51 UTC
Description:
UI: Sidebar panel resizing is inconsistent

Steps to Reproduce:
1. Open Writer
2. Go to the different panels and try to resize them. Some panels can be smaller compared to others

Actual Results:
The minimum size of a panel is different for different panels. However the size gets inherited.. So it's possible to downside a panel witch by itself doesn't allow this

Expected Results:
Similar as with they Paragraph style dialog. Take the minimum size of the 'largest' panel and set it as minimum size for all


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: ru-RU (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-06 12:15:12 UTC
Created attachment 164002 [details]
Screencast
Comment 2 Telesto 2020-08-06 12:22:33 UTC Comment hidden (obsolete)
Comment 3 Telesto 2020-08-06 12:24:18 UTC
@Caolan
You have invented the system to define the size of the dialog based on the 'largest' tab for Page Style dialog. Is the same technique also possible for defining the minimum size for the sidebar decks?

FWIW, I assume this to be a duplicate.. expect they Style Exporting downsizing being new..
Comment 4 V Stuart Foote 2020-08-06 15:10:12 UTC
This has been covered in bug 90374 and its dupes, including your bug 104112.

And fyi, Sidebar UI configuration by lo module was implemented by Caolán with https://cgit.freedesktop.org/libreoffice/core/commit/?id=b1314f22eb8de4359b5360194c04996351e9a6c2 and made persistence in profile with work on bug 67770

And where controls were affected those content panels were adjusted, e.g. bug 109385

Still a few annoyances, size of decks with UI scaling done for HiDPI bug 128243, or ability to reset Sidebar to defaults bug 105131 but the framework and general function of the Sidebar is somewhat established--i.e. no major changes, and just refinement which this is not.
Comment 5 V Stuart Foote 2020-08-06 15:11:32 UTC

*** This bug has been marked as a duplicate of bug 90374 ***