Bug 135582 - Cannot remove password protection from .xls file in 7.0.0
Summary: Cannot remove password protection from .xls file in 7.0.0
Status: RESOLVED DUPLICATE of bug 133771
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks: Password-Protected
  Show dependency treegraph
Reported: 2020-08-09 15:09 UTC by Theodore Lytras
Modified: 2020-08-10 08:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Theodore Lytras 2020-08-09 15:09:17 UTC
After normally opening a password-protected .xls file, I cannot remove the protection by "Save as" and having the "Save with password" checkbox unticked. When I open the file it is still password-protected.

Steps to Reproduce:
1. Open a password-protected .xls file (or .ods -- tried that as well)
2. "Save as" a new .xls or .ods file. The "Save with password" checkbox must be unchecked.
3. Open the new file

Actual Results:
The .xls/.ods file is still password-protected, libreoffice calc still prompts for a password.

Expected Results:
The .xls/.ods file should have been opened without asking for a password.

Reproducible: Always

User Profile Reset: Yes

Additional Info:
Behaviour happens with Libreoffice 7.0.0 in Debian testing. Previous version 6.4.5 was OK.
When clicking "Save as", the "Save with password" checkbox initially appears unchecked. Checking and unchecking has no effect, same behaviour.
Tried "Save as" a different file format (.xlsx/.xls/.odt), no difference, new file is still password-protected.
Checking the "Save with password" checkbox and specifying a different password works OK, the new file can be opened with the updated password.
Although my problem was with Excel-created .xls files, I also tried with .ods files created by LibreOffice. If they are saved with a password, then it becomes impossible to remove that password.

Not sure whether this is related to bugs #134332 and #134796, as in my case the file opens and saves normally, I just cannot remove the password.
Comment 1 Roman Kuznetsov 2020-08-09 18:52:02 UTC
repro in

Version: (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
Потоков ЦП: 4; ОС: Windows 6.1 Service Pack 1 Build 7601; Отрисовка ИП: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); ИП: ru-RU
Calc: CL

but not in 6.4.5 version => regression
Comment 2 Aron Budea 2020-08-10 07:53:42 UTC
Seems like a dupe of bug 133771.

*** This bug has been marked as a duplicate of bug 133771 ***