Bug 135601 - Table in Impress doesn't grow when adding text
Summary: Table in Impress doesn't grow when adding text
Status: RESOLVED DUPLICATE of bug 137949
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-08-10 10:16 UTC by Telesto
Modified: 2020-11-09 14:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (12.19 KB, application/vnd.oasis.opendocument.presentation)
2020-08-10 10:16 UTC, Telesto
Details
Screencast (569.41 KB, video/mp4)
2020-08-11 12:43 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-10 10:16:46 UTC
Description:
Table in Impress doesn't grow when adding text

Steps to Reproduce:
1. Open the attached file
2. Type something into the empty cells. More then 3 lines. Say B followed by Enter (5x)

Actual Results:
Table size isn't update after enter

Expected Results:
Should


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1
5.4

not in
4.4.7.2
Comment 1 Telesto 2020-08-10 10:16:58 UTC
Created attachment 164095 [details]
Example file
Comment 2 Xisco Faulí 2020-08-11 08:52:31 UTC
I can't reproduce it in

Version: 7.1.0.0.alpha0+
Build ID: 0de191e1d201d691c2196cf1aef412a98affb66f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

The table resizes after clicking outside the cell. Please recheck. Screencast also missing
Comment 3 Telesto 2020-08-11 12:43:51 UTC
Created attachment 164157 [details]
Screencast

Screencast of 4.4.7.2 (expected) and current (7.1) broken
Comment 4 BogdanB 2020-08-12 17:51:45 UTC
I confirm it was working in 3.6.7.2 (I can not test on 4.4.7.). 

And I confirm it is NOT working on 5.4.
Comment 5 raal 2020-08-15 20:06:10 UTC
Works for me in Version: 7.1.0.0.alpha0+
Build ID: ce6c6a5ad6c9dde09bb0bb0c51e16d828cfe0ef7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
and Version: 7.1.0.0.alpha0+
Build ID: ce6c6a5ad6c9dde09bb0bb0c51e16d828cfe0ef7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

Windows only bug?
Comment 6 Telesto 2020-08-15 20:56:22 UTC
I repro this - using cell B1 - on Linux too (x11)
Comment 7 raal 2020-08-16 06:24:20 UTC
(In reply to Telesto from comment #6)
> I repro this - using cell B1 - on Linux too (x11)

Sorry, my mistake. It's on linux too.
Comment 8 raal 2020-08-16 06:30:10 UTC
This seems to have begun at the below commit.
Adding Cc: to Xisco Fauli; Could you possibly take a look at this one?
Thanks

bibisect-linux-64-5.2$  bc71e01bfa445788b7e4d18bd118aa49fe189a0a is the first bad commit
commit bc71e01bfa445788b7e4d18bd118aa49fe189a0a
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sat Dec 9 21:25:19 2017 +0100

    source sha:13d4398820ded5914f635757865e258db2db2b57

author	Xisco Fauli <anistenis@gmail.com>	2016-01-21 20:56:31 +0100
committer	jan iversen <jani@documentfoundation.org>	2016-01-30 07:40:22 +0000
commit 13d4398820ded5914f635757865e258db2db2b57 (patch)
tree 356431bab06546113e07462070948388e3d6fc6e
parent 2416a2965f4d51e1b14b8539436f5f8fc16cc399 (diff)
tdf#91762: Check wether the row and the cell have text...
Comment 9 Xisco Faulí 2020-11-04 22:28:54 UTC

*** This bug has been marked as a duplicate of bug 120365 ***
Comment 10 Xisco Faulí 2020-11-09 14:10:15 UTC
This issue is fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=b7b05dd36403af50b20fe06cbf8a10d8defb28a9
Closing as dupe of bug 137949

*** This bug has been marked as a duplicate of bug 137949 ***