Download it now!
Bug 135605 - Navigator: Clicking on text expands all same-level headings in navigator
Summary: Navigator: Clicking on text expands all same-level headings in navigator
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2020-08-10 11:19 UTC by R. Green
Modified: 2020-08-12 13:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer file showing a problem with the display of headings in the navigator (122.73 KB, application/vnd.oasis.opendocument.text)
2020-08-10 11:19 UTC, R. Green
Details
Zip file of before and after navigator views (21.01 KB, application/x-zip-compressed)
2020-08-10 16:35 UTC, R. Green
Details

Note You need to log in before you can comment on or make changes to this bug.
Description R. Green 2020-08-10 11:19:16 UTC
Created attachment 164105 [details]
Writer file showing a problem with the display of headings in the navigator

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: threaded

I didn't have this issue in version 6.

1. Open the attached file, and in "Chapter 1" click on any "Heading 4" or even the body text itself.

EXPECTED RESUlT: The display in the Navigator should not change at all. The levels of the Navigator should only expand and contract when the USER clicks on them in the Navigator.

ACTUAL RESULT: All the headings of the same level expand in the Navigator. In books where there may be lots of subheading in each chapter, this badly affects the usability of the display, where navigating from chapter to chapter is paramount.

In other words, the Navigator is making it difficult to see the wood for the trees.
Comment 1 Xisco Faulí 2020-08-10 16:10:11 UTC
I don't reproduce the problem in

Version: 7.1.0.0.alpha0+
Build ID: 6ad2f463784a24c566477cdd60ae729651bb8564
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Please, add a screencast
Comment 2 R. Green 2020-08-10 16:35:47 UTC
Created attachment 164121 [details]
Zip file of before and after navigator views

Perhaps it's now fixed in your version? But anyway, here's a better description:

1. Open the attached writer file. the Navigator (F5) should be visible (in my case I have it undocked on the left side).
2. Without touching the document area yet, inspect the navigator and verify that it looks like the image attached (nav_before): i.e. only the level 3 headings (Chapter 1 etc.) are visible.
3. Scroll to page 2 and click on the first sentence ("He heard quiet steps behind him. That didn't bode well. Who …").

EXPECTED RESULT: The Navigator view should still be the same as "nav_before", with only the level 3 headings visible: i.e. The navigator levels should only open and close when you click on the +/- buttons.

ACTUAL RESULT: The navigator view looks like "nav-after". The first level 3 heading (Chapter 1) has expanded to reveal all the level 4 headings. But it shouldn't have because I have not clicked on the relevant + button in the navigator.
Comment 3 Dieter 2020-08-11 11:13:57 UTC
I confirm that behaviour with

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

I agree, that this is not the expected behaviour, but I might be wrong

@ Jim Raykowski: Jim, I'm sure you can assess, if it is expected or not
Comment 4 Jim Raykowski 2020-08-11 18:12:19 UTC
This is the default behavior as requested by enhancement bug 108766. 

There is option to turn this behavior off in the Headings context menu under the Outline Tracking sub menu. To access the context menu right click in the Navigator on either Headings or any of it's content. Another way to prevent this is by setting the highlighted item in the Navigator content to any non heading content, e.g. Tables.
Comment 5 Dieter 2020-08-12 12:55:53 UTC
(In reply to Jim Raykowski from comment #4)
> This is the default behavior as requested by enhancement bug 108766. 

=> NOTABUG
Comment 6 R. Green 2020-08-12 13:22:52 UTC
Added documentation request: Bug 135668.