Bug 135633 - Image border not being copied with the inserted image when it is pasted outside Writer
Summary: Image border not being copied with the inserted image when it is pasted outsi...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Borders
  Show dependency treegraph
 
Reported: 2020-08-11 11:42 UTC by Aditya Sahu
Modified: 2021-05-04 13:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aditya Sahu 2020-08-11 11:42:14 UTC
Description:
After inserting an image in LibreOffice Writer and adding borders to it; I copy the now changed image (with borders) and paste it somewhere else (outside Writer) only to find out that the raw image was copied - without the borders.

Steps to Reproduce:
1. Insert an image in Writer
2. Add borders to it
3. Copy the image
4. Paste it outside Writer

Actual Results:
After pasting the image with borders outside Writer, the pasted image does not contain borders

Expected Results:
After pasting the image, the image should contain border as well


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 301b56f92b9058731f76e32604a771cac460693d
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: en-IN (en_IN); UI: en-US
Calc: threaded
Comment 1 Regina Henschel 2020-08-11 22:45:38 UTC
The reason is, that "borders" of an image do not exist in Calc, Draw or Impress. The border in Writer does not really belong to the image. If you rotate the image a little bit, then you will see, that the borders remain upright.

It would be necessary to convert the "border" to a "line" (technically a "stroke"). The question is whether LibreOffice should do this automatically or on request. And what should happen with the "border" of a rotated image.
Comment 2 Buovjaga 2021-04-28 15:45:03 UTC
(In reply to Regina Henschel from comment #1)
> The reason is, that "borders" of an image do not exist in Calc, Draw or
> Impress. The border in Writer does not really belong to the image. If you
> rotate the image a little bit, then you will see, that the borders remain
> upright.
> 
> It would be necessary to convert the "border" to a "line" (technically a
> "stroke"). The question is whether LibreOffice should do this automatically
> or on request. And what should happen with the "border" of a rotated image.

Design team might consider this
Comment 3 Heiko Tietze 2021-05-04 13:24:58 UTC
(In reply to Regina Henschel from comment #1)
> question is whether LibreOffice should do this automatically or on request

Without a clear use case / scenario I don't see need to make Writer an editor for raster graphics. No need to automatically convert attributes. => WF