Bug 135711 - Crash saving a document with columns and image anchored to page to DOCX (since 7.1)
Summary: Crash saving a document with columns and image anchored to page to DOCX (sinc...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2020-08-13 12:41 UTC by Telesto
Modified: 2020-09-14 07:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (49.43 KB, application/vnd.oasis.opendocument.text)
2020-08-13 12:41 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-13 12:41:10 UTC
Description:
Crash saving a document with columns and image anchored to page to DOCX

Steps to Reproduce:
1. Open the attached file
2. Save As DOCX -> crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Repro with
7.1

not with
Version: 6.4.0.0.beta1+ (x64)
Build ID: 20be5cd0bdc57d812bf34a2debfe48caa51de881
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-08-13 12:41:25 UTC
Created attachment 164255 [details]
Example file
Comment 2 Xisco Faulí 2020-08-13 13:33:37 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fd88bb81236ad6d1a63436b7ce20f2f93410d359

author	Bakos Attila <bakos.attilakaroly@nisz.hu>	2020-07-16 16:56:33 +0200
committer	László Németh <nemeth@numbertext.org>	2020-07-23 17:28:00 +0200
commit	fd88bb81236ad6d1a63436b7ce20f2f93410d359 (patch)
tree	6f43ae2a87f7aa5090830566cbd76f0060aa555a
parent	27c1a7fbcd3e236d4eee7ee3e1a7acdaa47510eb (diff)
tdf#107225 tdf#122887 sw: fix reanchoring of textboxes

Bisected with: bibisect-linux64-7.1

Adding Cc: to Bakos Attila
Comment 3 Aron Budea 2020-08-13 19:55:13 UTC
Since the commit wasn't backported to 7.0, this bug must be 7.1 only so far.
Comment 4 Commit Notification 2020-08-31 09:11:17 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5162647096fa061ae0a4ad5d4e1fd015fbeb9871

tdf#135711: DOCX export: fix crash on page anchored textboxes

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 NISZ LibreOffice Team 2020-09-14 07:43:22 UTC
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded