Bug 135727 - [ko] Extend Autocorrect list for Korean language
Summary: [ko] Extend Autocorrect list for Korean language
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.2.0 target:7.1....
Keywords: difficultyBeginner, easyHack, topicDoc, topicQA
Depends on:
Blocks: AutoCorrect-Complete CJK-Korean
  Show dependency treegraph
 
Reported: 2020-08-13 17:40 UTC by DaeHyun Sung
Modified: 2022-05-09 10:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DaeHyun Sung 2020-08-13 17:40:03 UTC
Description:
This is only for native speakers of Korean language.

Info about the autocorrect feature: https://help.libreoffice.org/6.4/en-US/text/shared/01/06040100.html?DbPAR=SHARED#bm_id3155620 
(Please read before starting!)

Location of the autocorrect file for Korean: extras/source/autocorr/lang/ko/DocumentList.xml

Example commit: https://gerrit.libreoffice.org/c/core/+/100682

Watching point: 국립국어원 한국어 어문 규범
http://kornorms.korean.go.kr/regltn/regltnView.do#a

Pay attention:
Please, check Korean Homophone words 



Steps to Reproduce:
1. input Korean word
2. write Korean words
명애훼손
명예홰손
명외훼손
명웨훼손
명회회손
3. check changed auto correct word '명예훼손'

Actual Results:
명애훼손
명예홰손
명외훼손
명웨훼손
명회회손

Expected Results:
명예훼손
명예훼손
명예훼손
명예훼손
명예훼손


Reproducible: Always


User Profile Reset: No



Additional Info:

Watching point: 국립국어원 한국어 어문 규범
http://kornorms.korean.go.kr/regltn/regltnView.do#a


check Korean words 오타체, 급식체, 통신체, etc.
Comment 1 Commit Notification 2020-08-19 20:41:38 UTC
OctopusET committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d622b7c73acac5a8c9dd34818aad1b0d80c00c44

tdf#135727 add Korean Autocorrect list

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2020-08-22 06:31:47 UTC
tgds03 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6c2911a483dd28b2006eb2579d7922f78c774577

tdf#135727 add Korean Autocorrect list

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2020-08-22 06:31:57 UTC
ramtk6726 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8a360d04e43410e729c0ee270be5447ce6c1cd03

tdf#135727 add korean autocorrect list

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-09-21 18:49:02 UTC
DaeHyun Sung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/23a5911a67269dcdf02042e0b7e8b187085301a7

tdf#135727 add Korean auto correct word

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-09-21 18:49:12 UTC
DaeHyun Sung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6e4a5e73bfd22a2410b960132c2702a6597ce6fb

tdf#135727 add Korean Autocorrect list

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-12-03 11:41:39 UTC
DaeHyun Sung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d23a2ebe43a27ab62d9c5c9c3f23e8939d73689d

tdf#135727 add & sorting Korean Autocorrect list

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-12-03 22:31:57 UTC
DaeHyun Sung committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8e9882b6d96367329a41e1f84ab1a880465bdf3f

tdf#135727 add & sorting Korean Autocorrect list

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-11-20 21:09:13 UTC
DaeHyun Sung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/69db2d21a71c1851b93ced42d663d409dc3039ed

tdf#135727 add autocorrect lists for Korean Language

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2022-05-03 11:49:54 UTC
A polite ping to DaeHyun Sung:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
Otherwise, Could you please explain what's missing?
Thanks
Comment 10 DaeHyun Sung 2022-05-07 07:35:37 UTC
(In reply to Xisco Faulí from comment #9)
> A polite ping to DaeHyun Sung:
> Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
> Otherwise, Could you please explain what's missing?
> Thanks

Sorry. I forgot to check because I was busy.
I was late for the confirmation due to various reasons, such as changing jobs and getting married from late 2021 to 2022.

I watched the TDF wiki's Skill Level: Beginner contents.
The one of contents is "Skill Level: Beginner"

update technical dictionary
https://bugs.documentfoundation.org/show_bug.cgi?id=87605

 
This issue, "Autocurrect list for Korean" requires a lot of Korean data and requires the participation of several Korean people, so I hope it remains New.

I benchmarked by looking at the status of "Bug 87605".
https://bugs.documentfoundation.org/show_bug.cgi?id=87605