Bug 135745 - Dragging anchor splits text box border from text after docx export
Summary: Dragging anchor splits text box border from text after docx export
Status: RESOLVED DUPLICATE of bug 122887
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Textbox DOCX-Textbox
  Show dependency treegraph
 
Reported: 2020-08-14 07:37 UTC by Telesto
Modified: 2020-10-30 14:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.17 KB, application/vnd.oasis.opendocument.text)
2020-08-14 07:37 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-14 07:37:35 UTC
Description:
Dragging anchor splits text box border from text after docx export

Steps to Reproduce:
1. Open the attached file
2. Select the textbox
3. pick the anchor and drag it outside the table -> fine
4. undo everything
5. Save as DOCX
6. File reload
7. repeat 2/3 -> wrong

Actual Results:
Textbox border an content split

Expected Results:
Same thing


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 1 Telesto 2020-08-14 07:37:53 UTC
Created attachment 164298 [details]
Example file
Comment 2 BogdanB 2020-09-15 17:52:38 UTC
On linux everything is the same, except 3 borders of the textbox seems to appear gray instead of black, but on preview are black.

Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 3 NISZ LibreOffice Team 2020-10-30 14:20:02 UTC
Not happening in 7.1alpha since:

https://git.libreoffice.org/core/+/fd88bb81236ad6d1a63436b7ce20f2f93410d359

author
Bakos Attila <bakos.attilakaroly@nisz.hu> Thu Jul 16 16:56:33 2020 +0200 
committer
László Németh <nemeth@numbertext.org> Thu Jul 23 17:28:00 2020 +0200 

tdf#107225 tdf#122887 sw: fix reanchoring of textboxes

*** This bug has been marked as a duplicate of bug 122887 ***