Bug 135759 - Some border lines look grayish like (no border set) after DOCX export (but are actually present)
Summary: Some border lines look grayish like (no border set) after DOCX export (but ar...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2020-08-14 11:57 UTC by Telesto
Modified: 2022-12-22 08:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.01 KB, application/vnd.oasis.opendocument.text)
2020-08-14 11:57 UTC, Telesto
Details
The example file and its docx-version in 7.2alpha (105.53 KB, image/png)
2020-12-03 16:55 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-14 11:57:26 UTC
Description:
Some border lines look grayish like (no border set) after DOCX export (but are actually present)

Steps to Reproduce:
1. Open the attached file
2. Save file as DOCX
3. File reload


Actual Results:
Left side of the middle square looks as if it has no border; this isn't the case go to print preview (everything OK)

Expected Results:
As fat as the rest


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-14 11:57:39 UTC
Created attachment 164312 [details]
Example file
Comment 2 Telesto 2020-08-14 12:00:26 UTC
Delete to to row to see where actual borders are disappearing
Comment 3 BogdanB 2020-08-14 12:02:34 UTC
Confirm on
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
Comment 4 BogdanB 2020-08-14 12:03:16 UTC
On preview is there. But on edit it looks gray.
Comment 5 BogdanB 2020-09-12 18:00:33 UTC
Repro in
Version: 5.4.7.2
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk2; 
Locale: ro-RO (ro_RO.UTF-8); Calc: group

Also in
Version 3.6.7.2 (Build ID: e183d5b)
Comment 6 NISZ LibreOffice Team 2020-12-03 16:55:12 UTC
Created attachment 167804 [details]
The example file and its docx-version in 7.2alpha

Seems to be good now in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4e63ec27b69fa01ff610c894c9fbf05c377a6179
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

But not yet on top of the bibisect-7.1 repo:

Version: 7.1.0.0.beta1+ (x64)
Build ID: f9fab4203c1aa0b9a3f27ce2713b6d5addc7df19
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

This one even shows badly the file saved by 7.2alpha.
Comment 7 NISZ LibreOffice Team 2020-12-04 07:09:44 UTC
(In reply to NISZ LibreOffice Team from comment #6)
> Created attachment 167804 [details]
> The example file and its docx-version in 7.2alpha
> 
> Seems to be good now in:
> 
False warning: this has to do with the View - Table boundaries setting: 
- if enabled, the light grey table boundary line is visible 
- if disabled, the black border line is visible

Does not happen with odt.
Comment 8 Justin L 2022-06-24 14:43:44 UTC
Better steps to reproduce would be nice here. It sounded to me like a duplicate of bug 140967, but it is confirmed prior to 7.0 so that can't be true.

In any case, it would be nice to have this reconfirmed, and a simpler example provided.
Comment 9 QA Administrators 2022-12-22 03:36:18 UTC Comment hidden (obsolete)
Comment 10 Telesto 2022-12-22 08:22:40 UTC
Unable to repro
Version: 7.6.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 8635c9aa8c6f1078a9e220076d5a08daf30077e8
CPU threads: 8; OS: Mac OS X 12.3.1; UI render: Skia/Metal; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded