Bug 135843 - FILEOPEN PPTX: extraneous/missing lines in table in Impress versus PowerPoint
Summary: FILEOPEN PPTX: extraneous/missing lines in table in Impress versus PowerPoint
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.4.0 target:7.3.0.3 target:7....
Keywords: bibisected, bisected, filter:pptx
: 115753 135552 (view as bug list)
Depends on:
Blocks: PPTX-Tables
  Show dependency treegraph
 
Reported: 2020-08-17 13:46 UTC by Gerald Pfeifer
Modified: 2022-05-20 14:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample PPTX slide (7.08 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-08-17 13:46 UTC, Gerald Pfeifer
Details
Screenshot comparison LibreOffice - PowerPoint (26.01 KB, image/png)
2020-08-17 13:53 UTC, Gerald Pfeifer
Details
How it looks in LibreOffice 7.1 master (24.62 KB, image/png)
2020-11-19 16:52 UTC, Xisco Faulí
Details
Visual comparison LibreOffice 7.4 vs Office 365 (76.41 KB, image/png)
2022-01-11 11:01 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-08-17 13:46:45 UTC
Created attachment 164378 [details]
Sample PPTX slide

Opening this slide in Impress shows two vertical lines inside the table
which Office 365 does not show.

Version: 6.4.4.2
Build ID: 40(Build:2)
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-16_13:25:48
Calc: threaded


This looks similar to (if the inverse) bug #130799 in case of Writer (which 
is resolved) or bug #131561 in Writer as well, though different there, too.
Comment 1 Gerald Pfeifer 2020-08-17 13:53:21 UTC
Created attachment 164379 [details]
Screenshot comparison LibreOffice - PowerPoint
Comment 2 Aron Budea 2020-08-20 09:18:32 UTC
Confirmed with LO 7.1.0.0.alpha0+ daily build from 08-15 / Windows.
The table style was completely missing in 6.3 and before. It might be interesting to know what change added that in 6.4, adding bibisectRequest.
Comment 3 Aron Budea 2020-09-12 00:38:48 UTC
The table style started showing after the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=7f82e6dae98bc5e75ec03885eb955a7a72047bb4
author		Gülşah Köse <gulsah.kose@collabora.com>	2019-12-27 21:06:08 +0300
committer	Andras Timar <andras.timar@collabora.com>	2020-01-07 10:19:11 +0100

tdf#107604 Handle predefined table styles.
Comment 4 Xisco Faulí 2020-11-19 16:52:28 UTC
Created attachment 167400 [details]
How it looks in LibreOffice 7.1 master

How it looks for me

Version: 7.1.0.0.alpha1+
Build ID: 2f7b5634487ac3d27777ab12a57089e71ea5216d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Gerald Pfeifer 2021-11-12 09:36:04 UTC
(In reply to Xisco Faulí from comment #4)
> Created attachment 167400 [details]
> How it looks in LibreOffice 7.1 master

In addition this shows an incomplete line at the bottom and the right side
of the table.
Comment 6 Gerald Pfeifer 2021-12-01 16:01:44 UTC
Gülşah, you assigned this to yourself and closed it without a comment
(nor do I see a commit automatically referred to in the comments here).

Was this intentional?
Comment 7 Xisco Faulí 2021-12-01 16:18:54 UTC
I believe she wanted to close bug 140912 instead, she just fixed it
Comment 8 Gülşah Köse 2021-12-01 19:10:32 UTC
I'just wanted to mark as ASSIGNED. Sorry for this. I started to work on that bug today.
Comment 9 Commit Notification 2022-01-06 14:17:19 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fa5ab8aa5d88e7128015127af75980a65f945cbb

tdf#135843 Fix the missing border handling

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2022-01-11 08:56:54 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/35b179b88330e1e94980192c598f23661e2757f9

tdf#135843 Fix the missing border handling

It will be available in 7.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Gerald Pfeifer 2022-01-11 11:01:47 UTC
Created attachment 177456 [details]
Visual comparison LibreOffice 7.4 vs Office 365

I noticed that even after the recent changes the original issue (two
extraneous vertical lines) is still present.
Comment 12 Gerald Pfeifer 2022-01-11 11:02:53 UTC
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: f1f2daefbe921d223079a50358527e1d35470850
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Comment 13 Gülşah Köse 2022-01-12 11:06:23 UTC
Hi Gerald, I'm on the bug. There was two separate issues. First commit solves the first one. I'm working on the second part now. Thanks for checking.
Comment 14 Commit Notification 2022-01-17 12:15:44 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/586a0f149f332c0b0e53c0bb30568d4bd411b0e3

tdf#135843 tdf#146731 Fix the missing border handling

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2022-01-18 09:14:03 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/58c1afd0590463177de83a90a848a83d0cfcc058

tdf#135843 tdf#146731 Fix the missing border handling

It will be available in 7.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2022-01-20 10:19:07 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3-0":

https://git.libreoffice.org/core/commit/2b819b95f999952fa324dff335130f2693ca2327

tdf#135843 tdf#146731 Fix the missing border handling

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2022-02-01 05:22:29 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/48575b3eb856406d9de406cb1d2de23866b0178f

tdf#135843 Do not export unused border lines.

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2022-03-02 10:57:51 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3faf005a367cbd28077403bf93810bbaf4805851

tdf#135843 Implement inside horizontal vertical borders.

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Gabor Kelemen (allotropia) 2022-03-03 09:09:07 UTC
*** Bug 115753 has been marked as a duplicate of this bug. ***
Comment 20 Gabor Kelemen (allotropia) 2022-03-03 09:20:08 UTC
*** Bug 135552 has been marked as a duplicate of this bug. ***
Comment 21 Gerald Pfeifer 2022-03-03 16:56:56 UTC
Happily verified with today's -dev build:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: fb9270b238cba4f36e595c5d7f4d85f6f3f18e1c
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Comment 22 Commit Notification 2022-03-04 07:28:52 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/96694528f3f4212070c90e8d61366bbbe35e991a

tdf#135843 Do not export unused border lines.

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2022-03-04 07:29:07 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/90f19b66d81b0a4958cacc40d2be0516f281d702

tdf#135843 Implement inside horizontal vertical borders.

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Regina Henschel 2022-03-04 16:15:02 UTC
Now saving to .odp is broken. I have written bug 147766 for it.
Comment 25 Commit Notification 2022-03-07 15:25:08 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/ea5a3e0247b1230c1fe7e2cb0afc597e56d0b4c2

Revert "tdf#135843 Implement inside horizontal vertical borders."

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2022-04-13 06:26:22 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/d2a2d16b4836bf62db7c32faffa0c5b6d0d30a5e

Revert "Revert "tdf#135843 Implement inside horizontal vertical borders.""

It will be available in 7.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2022-05-20 14:17:29 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ff0387e726b59e374029d2f635ce00308d99eff6

tdf#135843: sd_export_tests-ooxml3: Add unittest for the export part

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.