Bug 135874 - Undo makes the initial selection larger (which can be annoying with drag & drop)
Summary: Undo makes the initial selection larger (which can be annoying with drag & drop)
Status: RESOLVED DUPLICATE of bug 141738
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Undo-Redo Selection
  Show dependency treegraph
 
Reported: 2020-08-18 09:37 UTC by Telesto
Modified: 2021-10-01 12:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (8.58 KB, application/vnd.oasis.opendocument.text)
2020-08-18 09:37 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-18 09:37:06 UTC
Description:
Undo makes the initial selection large (which can be annoying with drag & drop)

Steps to Reproduce:
1. open the attached file
2. Double click "lightning"
3. Drag it Between "the alley" -> Fine
4. CTRL+Z
5. Drag it again assuming the undo selection being the same as the initial selection'
6. Green highlighting is included this time

Actual Results:
Character before included in selection after undo

Expected Results:
From usability point of view not


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-18 09:37:25 UTC
Created attachment 164404 [details]
Example file
Comment 2 Telesto 2020-08-18 09:39:24 UTC
Also in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Dieter 2021-03-28 09:59:48 UTC
Telesto, it seems, that nobody could confirm this bug since more than one year. So Iā€˜d like to ask, if it is still reproducible for you. Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/current.html? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 QA Administrators 2021-09-26 03:58:23 UTC Comment hidden (obsolete)
Comment 5 Telesto 2021-09-27 18:31:16 UTC
Still behaving the same
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d5e55d204b71710eb5eb5d2c683dd6698626df3c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (nl_NL); UI: en-US
Calc: CL
Comment 6 Dieter 2021-10-01 08:37:15 UTC
I confirm it with

Version: 7.2.1.2 (x64) / LibreOffice Community
Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Please see your own bug 141738 (SELECTION: It's not visible, that blank space before the word is also selected, if you double-click a word)

So I support consistency here, but please decide, what you want

a) double click should also select blank space before
b) blank space before shouldn't be inculded after undo

=> NEEDINFO
Comment 7 Telesto 2021-10-01 10:20:29 UTC
(In reply to Dieter from comment #6)
> I confirm it with
> 
> Version: 7.2.1.2 (x64) / LibreOffice Community
> Build ID: 87b77fad49947c1441b67c559c339af8f3517e22
> CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL:
> win
> Locale: de-DE (de_DE); UI: de-DE
> Calc: CL
> 
> Please see your own bug 141738 (SELECTION: It's not visible, that blank
> space before the word is also selected, if you double-click a word)
> 
> So I support consistency here, but please decide, what you want
> 
> a) double click should also select blank space before
> b) blank space before shouldn't be inculded after undo
> 
> => NEEDINFO

Based on the logic, I would opt for B. A blank space isn't always added. I even could argue the insertion of empty space before being wrong in general. A space being inserted out of nowhere . But Heiko sees empty space insertion as feature, not a bug IIRC. In that case this being side-effect (bug), caused by the feature.
Comment 8 Dieter 2021-10-01 12:46:12 UTC
I had a closer look inside.

Since you have a blank space before and after lighting, you can easily see, that one space is dragged together with the word "lighting", because otherwise there would be two spaces at the end. And undo makes this visible. So the bug you describe is just a variant of bug 141738

*** This bug has been marked as a duplicate of bug 141738 ***