Bug 135940 - Frame transparent (wrap through) in header with DOCX but not in DOC
Summary: Frame transparent (wrap through) in header with DOCX but not in DOC
Status: RESOLVED DUPLICATE of bug 104254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError
Depends on:
Blocks: DOCX-Frames DOCX-Anchor-and-Text-Wrap Shape-ODF-OOXML-export
  Show dependency treegraph
 
Reported: 2020-08-20 08:52 UTC by Telesto
Modified: 2021-07-19 07:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (10.88 KB, application/vnd.oasis.opendocument.text)
2020-08-20 08:52 UTC, Telesto
Details
The example file and its docx version in 7.1 (104.84 KB, image/png)
2021-07-16 07:42 UTC, NISZ LibreOffice Team
Details
The original and its docx version in Writer 7.2 and in Word as well (104.95 KB, image/png)
2021-07-16 07:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-20 08:52:42 UTC
Description:
Frame transparent (wrap through) in header with DOCX but not in DOC

Steps to Reproduce:
1. open the attached file
2. Save as DOCX
3. File reload

Actual Results:
Wrap through

Expected Results:
Like the DOC behavior


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in
4.4.7.2

not in
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 1 Telesto 2020-08-20 08:52:56 UTC
Created attachment 164487 [details]
Example file
Comment 2 Telesto 2020-08-20 08:57:25 UTC
Already in 4.3
Comment 3 Aron Budea 2020-08-21 23:36:49 UTC
Confirmed using LO 7.1.0.0.alpha0+ (e69fafe1873e4afbe739f21f7a82a069cf7eb5b2) / Windows.
Comment 4 raal 2020-08-30 17:04:11 UTC
unable to bibisect with bibisect-43max, lots of crashes
Comment 5 Aron Budea 2020-10-27 22:55:22 UTC
Bibisected to the following commit using repo bibisect-win32-4.3. This is an implementation error, and not a regression.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=41927dce4217d60808a889f8dac546f55848eead
author		Miklos Vajna <vmiklos@collabora.co.uk>	2013-12-23 14:25:37 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2013-12-23 15:06:54 +0100

sw: enable drawingml export of textframes by default
Comment 6 NISZ LibreOffice Team 2021-07-16 07:42:10 UTC
Created attachment 173623 [details]
The example file and its docx version in 7.1

The original frame does not seem to have the In Background setting, but the DOCX version when imported in Writer (but not in Word!), does in:

Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded
Comment 7 NISZ LibreOffice Team 2021-07-16 07:59:30 UTC
Created attachment 173624 [details]
The original and its docx version in Writer 7.2 and in Word as well

This changed significantly in 7.2 with:

https://git.libreoffice.org/core/+/798b69087119c01a3b51e0bb3240ef35cfededeb

author	Daniel Arato (NISZ) <arato.daniel@nisz.hu>	Wed Mar 24 20:18:16 2021 +0100
committer	László Németh <nemeth@numbertext.org>	Fri May 21 08:00:33 2021 +0200

tdf#104254 sw DOCX import: fix text wrapping in headers

Despite the commit message, this turned on the text wrapping in headers not only for DOCX files but ODT as well. 
The DOCX export now looks pretty much like it does in Word, this is an improvement.
The shape is not in background anymore, the text does not flow through it - another improvement.

Now the ODT also considers the wrap, this is why it has changed - but I'd argue it changed for the better, as in the wrap setting is now actually applied.

Another independent, still valid problem is an export problem: ODT is set to wrap "After" which is exported incorrectly, as it shows as "Optimal" after reopen.
Word sees it as Square wrap with "Where there is more space" instead of "Only on the right" as "Wrap side" (sorry I'm translating back from my Hungarian Word UI).
Setting it manually creates a wrap layout similar to the ODT original.
I'll report this in a new bug.
Comment 8 NISZ LibreOffice Team 2021-07-16 08:13:42 UTC
Let me close this as a duplicate. And we should be aware that images, frames etc. are now correctly wrapped in 7.2 - in case users notice :).

*** This bug has been marked as a duplicate of bug 104254 ***