Bug 135963 - Frame not restored after undo
Summary: Frame not restored after undo
Status: RESOLVED DUPLICATE of bug 135001
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2020-08-20 22:45 UTC by Telesto
Modified: 2020-08-31 20:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (60.44 KB, application/vnd.oasis.opendocument.text)
2020-08-20 22:45 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-20 22:45:31 UTC
Description:
Frame not restored after undo

Steps to Reproduce:
1. Open the attached file
2. CTRL+A
3. CTRL+Backspace
4. Select the remaining frame
5. Backspace or delete
6. Undo everything

Actual Results:
Image frame doesn't return

Expected Results:
Should


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-20 22:45:44 UTC
Created attachment 164513 [details]
Example file
Comment 2 Telesto 2020-08-20 22:47:17 UTC
No repro with
Version: 6.2.0.0.alpha0+
Build ID: 401cba4c20fbc930f034168872642428d7459218
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Telesto 2020-08-20 22:48:55 UTC
Also in
Version: 6.4.0.0.beta1+ (x64)
Build ID: 20be5cd0bdc57d812bf34a2debfe48caa51de881
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 4 Aron Budea 2020-08-21 21:38:27 UTC
For me, Ctrl+Backspace doesn't delete much, so I just used backspace.
In fact, there's an even simpler repro, simply select the frame, delete it, and undo.

Confirmed using LO 7.1.0.0.alpha0+ (e69fafe1873e4afbe739f21f7a82a069cf7eb5b2), 6.2.0.3 / Windows.
No repro in 6.1.0.3.
Comment 5 raal 2020-08-25 15:03:25 UTC
bisected with repo 6.3 to:
There are only 'skip'ped commits left to test.
The first bad commit could be any of:
023f512a0fb6a5516a0d143413b05e99e7bf5a3e  >  source sha:eb29623cf0614030a61c02b06ccbf06199c4f94e  > Caolán McNamara <caolanm@redhat.com> stray fprintf
81ebd9c6cbf898d00f353c9944359a9c53473fd5  > source sha:866f10e75ddcd9dcfa327d02f587a1f322e6b6b5   > Thorsten Behrens  sw_redlinehide: fix tdf#113479 by removing nag dialog
e288de81c88411ac8c24cc5d69d168f79108b290  > source sha:d72ea08b915f72efb70c97aa1ee90c919da5b5ab  > Caolán McNamara Resolves: tdf#122168 width/height transposed
9f829ceb2fcb4836d15278068966f851e0fe8e8e  > source sha:09657e3166e875f280095bf7d2f1f2ca8e022803  > Michael Stahl sw_redlinehide_4b: tdf#113479 SetRedlineFlags() calls no longer...
c74755c1e871f00c8895b1a23c9821c1123a3093  > source sha:faac30002b5a2af6050d440456e09dccedb15fee  > Caolán McNamara forcepoint#75 avoid move of table in footnote
4122f019d5bb167c67ebb2dd149c0ee05644eed1  > source sha:a9d4f2bebda3380a3b6843f9df1204c9b062b3a8  > Lionel Elie Mamane postgresql: correctly implement XMultipleResults interface
ac28baddff8767f709f806deeb1226f11ff7ac5c  > source sha:4aa66236d69c63b648a966de2e2d7a3f12eed8de  > Aleksei Nikiforov Qt5: Fix fullscreen window size
4e70a800ff4b0db5e2f8fef404e84ac18620faba  > source sha:5658da22f77a48599bb20cf6c7c37abf0388186e  > Jens Carl tdf#45904 Move XNameAccess Java tests to C++
82c53b8a52dd283644c812d22cb7dc48b20faf56  >  source sha:aa41e17e809a5398974b3b5f53a41c6632df284c
8655e42dd876ffedb00f6a0e4f9305cc904ac6b7  > source sha:d41bc9bd9359eb83f807fdfa72dbde0831f39be8  > Katarina Behrens tdf#122055: catch RuntimeException if a11y context no longer alive
c2d3e1a7730a846e554f4be76460df8683084956  > source sha:ec291d1ad0581688522cd1f1d341ad4345b14885  > Jens Carl tdf#45904 Move XElementAccess Java tests to C++
15ac2808c660ee03981c0521e9d799830ec38f57  > source sha:3ff6f789b063fd24e8dd7cf956a8141ce3060d80  > Jens Carl  Add missing header
3c02556c08d543484149b14e3f4747644b79c5fe  >  source sha:32902f66e7749b2d06d13f50416be5323a0c0ea9 > Michael Stahl sw_redlinehide: make layout based Show/Hide mode the default
92310406078bd8bdcd411a1a287aeca4767d0b5e  > source sha:6aaae44da382f4bc3eafc287b4a21734b740cf21  > Michael Stahl sw_redlinehide_4b: visibility of flys anchored at empty nodes
We cannot bisect more!

Adding CC to: Michael Stahl
Comment 6 Michael Stahl (CIB) 2020-08-31 14:50:33 UTC
i imagine step 3 is Backspace? because Ctrl+Backspace doesn't do anything for me (delete to start of sentence)

with that tweak it looks like a duplicate of bug 135001

*** This bug has been marked as a duplicate of bug 135001 ***
Comment 7 Telesto 2020-08-31 20:12:27 UTC
Indeed backspace.. and will check tomorrow.. my build is again outdated after the changes you made