Download it now!
Bug 135973 - FILESAVE DOCX: Restart Numbering (text:start-value="1") Not Reserved
Summary: FILESAVE DOCX: Restart Numbering (text:start-value="1") Not Reserved
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:6.4.7
Keywords: bibisected, regression
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2020-08-21 08:15 UTC by Kevin Suo
Modified: 2020-08-27 11:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test ODT File (12.53 KB, application/vnd.oasis.opendocument.text)
2020-08-21 08:15 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2020-08-21 08:15:16 UTC
Created attachment 164519 [details]
Test ODT File

The attached ODT file contains two-level numbering list text. The 2nd level in Chapter 2 is set to restart numbering, so its numbering should be 1 and 2. However, when save as DOCX, it becomes 3 and 4.

Steps to Reproduce:
1. Save the attached ODT file to DOCX.
2. Open the saved DOCX with Writer, or with MSO.

Current Result:
Chapter 1 Heading
    1. Chapter 1 Point 1
    2. Chapter 1 Point 2
Chapter 2 Heading
    3. Chapter 2 Point 1
    4. Chapter 2 Point 2

Expected Result:
Chapter 1 Heading
    1. Chapter 1 Point 1
    2. Chapter 1 Point 2
Chapter 2 Heading
    1. Chapter 2 Point 1
    2. Chapter 2 Point 2

版本: 6.4.6.2
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU 线程: 4; 操作系统: Linux 5.7; 界面渲染: 默认; VCL: gtk3; 
区域语言: zh-CN (zh_CN.UTF-8); UI 语言: zh-CN
Calc: threaded
Comment 1 BogdanB 2020-08-21 08:32:46 UTC Comment hidden (ignore, obsolete)
Comment 2 BogdanB 2020-08-21 08:34:27 UTC
Confirm it with 7.0

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
Comment 3 Kevin Suo 2020-08-21 08:37:46 UTC
My bibisecting suggests that it's a regression caused by any of the following:
f8211e84a5239de25fe6dc45a4bb6b6f8673a1ee..ea414f8f255d75e3be71c0d65731ff3f42f589ed

Age	        Commit message
2020-05-11	sw from-bottom relative orientation: link ODF proposal
2020-05-11	tdf#132766: DOCX export: always try to set bullet font for list
2020-05-11	tdf#95189: docx import: apply list ovverride only once	Vasily

Adding Vasily Melenchuk to cc list: Would you please take a look?
Comment 4 Kevin Suo 2020-08-21 08:38:43 UTC Comment hidden (obsolete)
Comment 5 BogdanB 2020-08-21 10:13:42 UTC Comment hidden (obsolete)
Comment 6 Timur 2020-08-21 22:31:12 UTC
(In reply to Kevin Suo from comment #3)
> Adding Vasily Melenchuk to cc list: Would you please take a look?
Added now.
Comment 7 Commit Notification 2020-08-24 09:11:55 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4e377914bf12fc3cc6b15ca4a99d6e755f141805

tdf#135973: DOCX export: improved list override support

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Kevin Suo 2020-08-24 12:30:36 UTC
Thanks for the fix. Could you please backport this to 6.4 branch as well?
Comment 9 BogdanB 2020-08-26 19:08:04 UTC
Solved.

Verified in
Version: 7.1.0.0.alpha0+
Build ID: 217122387f6e0ef657b8ba85eae082b448901cec
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 10 Commit Notification 2020-08-27 08:41:10 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/892329fc88116cbe70f0d92f8d307775840595b4

tdf#135973: DOCX export: improved list override support

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-08-27 10:59:33 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/2bc32e96df52e7f49b51881aa8f0dc97961c4f60

tdf#135973: DOCX export: improved list override support

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Kevin Suo 2020-08-27 11:45:50 UTC
Thank you!