Bug 135985 - Image caption frame with image inside interactive frame wrongly positioned after DOCX export (to paragraph/to character anchor)
Summary: Image caption frame with image inside interactive frame wrongly positioned af...
Status: RESOLVED DUPLICATE of bug 121509
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2020-08-21 10:06 UTC by Telesto
Modified: 2020-12-05 04:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (54.21 KB, application/vnd.oasis.opendocument.text)
2020-08-21 10:06 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-21 10:06:29 UTC
Description:
Image caption frame with image inside interactive frame wrongly positioned after DOCX export

Steps to Reproduce:
1. Open the attached file
2. Save as DOCX
3. File reload

Actual Results:
Image out of frame

Expected Results:
Inside


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

6.0

different but still broken in
4.4.7.2

no image frame in
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 1 Telesto 2020-08-21 10:06:41 UTC
Created attachment 164530 [details]
Example file
Comment 2 NISZ LibreOffice Team 2020-12-04 11:19:27 UTC
This is likely the same problem as bug #121509
On exporting frames they are converted to shapes. But shapes cannot be embedded inside other shapes in Word/Docx, so the embedded one falls out of the other.

*** This bug has been marked as a duplicate of bug 121509 ***