Bug 136015 - FILEOPEN: Formula's become blurred rendered images after DOC export
Summary: FILEOPEN: Formula's become blurred rendered images after DOC export
Status: RESOLVED DUPLICATE of bug 129244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-08-22 18:32 UTC by Telesto
Modified: 2020-09-01 12:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (14.02 KB, application/vnd.oasis.opendocument.text)
2020-08-22 18:32 UTC, Telesto
Details
Bibisect log (2.75 KB, text/plain)
2020-08-23 13:00 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-22 18:32:20 UTC
Description:
Formula's become blurred rendered images after DOC export (spin off of bug 135999)

Steps to Reproduce:
1. open the attached file
2. Save as DOC
3. File reload

Actual Results:
Blurred formula

Expected Results:
Sharp & crips


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in
Version: 6.4.0.0.beta1+ (x64)
Build ID: 20be5cd0bdc57d812bf34a2debfe48caa51de881
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

not in
6.2
Comment 1 Telesto 2020-08-22 18:32:35 UTC
Created attachment 164568 [details]
Example file
Comment 2 Telesto 2020-08-23 13:00:26 UTC
Created attachment 164596 [details]
Bibisect log

Bisected to
author	Xisco Fauli <xiscofauli@libreoffice.org>	2019-10-21 17:41:52 +0200
committer	Xisco Faulí <xiscofauli@libreoffice.org>	2019-10-24 11:30:38 +0200
commit	83baaec3a087f83d0ad3371d55671d9496771586 (patch)
tree	bb83645345f3aa9748303659ed8a9784273c0f7f
parent	6a45c9755293f0969b4c2081d6d602bac9986d16 (diff)
tdf#115967: Revert "sw: Use primitive renderer for graphics"
This reverts commit 302af8c2da58719844d22483b65a9fe5b3674684

I would like to revert it until a better solution is proposed
due to the number of duplicates already reported

After the commit, Libo exports LTR formulas in RTL documents to PDF
as RTL formulas

it also introduced other problems like tdf#112513 and tdf#117560

Unittest added

https://cgit.freedesktop.org/libreoffice/core/commit/?id=83baaec3a087f83d0ad3371d55671d9496771586
Comment 3 Telesto 2020-08-23 13:01:56 UTC
Adding CC to: Xisco Fauli
Comment 4 Telesto 2020-08-23 13:05:04 UTC
Adding CC to: Armin Le Grand

As this is caused by reverting "sw: Use primitive renderer for graphics"
Commit 302af8c2da58719844d22483b65a9fe5b3674684
Comment 5 V Stuart Foote 2020-08-23 13:52:24 UTC
Bisection is not useful. Asking to revert a reversion ;-)

Meanwhile Armin has moved forward with other work on primitive graphics. And bitmap gets the short end of the stick--https://gerrit.libreoffice.org/c/core/+/92048
Comment 6 Telesto 2020-08-23 23:00:15 UTC
(In reply to V Stuart Foote from comment #5)
> Bisection is not useful. Asking to revert a reversion ;-)
> 
> Meanwhile Armin has moved forward with other work on primitive graphics. And
> bitmap gets the short end of the
> stick--https://gerrit.libreoffice.org/c/core/+/92048

Happily to add bibisect again.. i'm pretty sure it did work... somewhere before sw: Use primitive renderer for graphics.

However, as the commit states: revert it until a better solution is proposed

And I assume Use primitive renderer for graphics is part of moving forward. So bisecting the point where it worked without this might be pointless..

Not a request to revert the revert.. or maybe it should be reverted and the regressions fixed instead.. As the revert breaks things too..

So more an invitation to look at this again.. as the revert is also breaking things
Comment 7 Xisco Faulí 2020-09-01 12:27:20 UTC
this is a fileopen issue
Comment 8 Xisco Faulí 2020-09-01 12:52:57 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=600a2aa24085cb972686b46061f9045785208a9e
Closing as duplicate of bug 129244

*** This bug has been marked as a duplicate of bug 129244 ***