Bug 136098 - Basic fonts size in Option is not saved
Summary: Basic fonts size in Option is not saved
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 136352 147641 148379 (view as bug list)
Depends on:
Blocks: Options-Dialog-Writer
  Show dependency treegraph
 
Reported: 2020-08-25 08:19 UTC by Jun Nogata
Modified: 2022-05-09 10:27 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jun Nogata 2020-08-25 08:19:38 UTC
Description:
Changing the Basic font size in the options does not save it.

Steps to Reproduce:
Language Settings
- Locale: Japanese
- Enable Asian: Default - Japanese

1. Open menubar [tools] -> [Options] (or Alt+F12) in Writer
2. Go to [LibreOffice Writer] -> [Basic Fonts(Western)] (and [Basic Fonts(Asian)])
3. Change all(Default, Heading, List, Caption, Index) font sizes to 9pt
4. Push [Ok] or [Apply] button and close options dialog
5. Open Options dialog again and go to Basic Fonts


Actual Results:
* Basic Fonts(Western): Caption font size reverted to 12pt
* Basic Fonts(Asian): List, Caption and Index font size reverted to 12pt


Expected Results:
The font size does not change.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
バージョン: 6.4.5.2
Build ID: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
CPU threads: 8; OS:Linux 5.7; UI render: default; VCL: gtk3; 
ロケール: ja-JP (ja_JP.UTF-8); UIの言語: ja-JP
Calc: threaded
Comment 1 Dieter 2020-08-26 06:15:20 UTC
I can't confirm it with

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ja-JP (de_DE); UI: en-GB
Calc: threaded
Comment 2 Julien Nabet 2020-09-01 10:17:42 UTC
*** Bug 136352 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nabet 2020-09-01 10:18:05 UTC
NEW since there's been confirmed with the dup
Comment 4 sdc.blanco 2021-02-17 15:38:10 UTC
1. Open Template Manager (Ctrl+Shift+N).
2. Search for "Default"
3. Open Default Template.
4. Open "Basic Fonts"  (Tools - Options - LibreOffice Writer - Basic Fonts)

5. Change Point Size for Caption, then press "Apply" 

Actual:  Reset to initial value
Expected: Keeps value.

6.  Change point size for Default, then press "Apply"

Actual:  Points size for "List" and "Index" also change.
Expected: only "Default" changes

7. Change point size of List  (to something different than Default), then press "Apply"

Actual:  value is reset to "default" point size value
Expected:  keeps specified value


Summary:  Does not seem possible to change point size for Caption at all.
          Changing point size of Default also changes List and Index.
          Not possible to change List to a different point size than Default
Comment 5 sdc.blanco 2021-02-17 15:39:21 UTC
comment 4 tested with:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 28555fc345ac2ccdda0e4e0f3c812c646befe68b
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DK); UI: en-US
Calc: threaded
Comment 6 Timur 2022-04-05 14:25:54 UTC
*** Bug 148379 has been marked as a duplicate of this bug. ***
Comment 7 Andreas Heinisch 2022-05-07 14:22:16 UTC
I can reproduce it in:
Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 6; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

First, you have to click the default button, and then change the font size. Apply/save does not save the font size.

However, in:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: b552aa80d0948fbf5734ec5ad4461db8f2f65827
CPU threads: 6; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

the error is gone.
Comment 8 Timur 2022-05-09 10:25:03 UTC
Good catch. Really seems resolved in 7.4. 
Although late, I set High because it's a core LO feature. 
After a tedious bibisect, here it is, also backported.

commit f5f372038820d98910f1283cd5592ed30819c221
sha:323ff2749b6be5f6ef98c6250afce4fa89e3aa1c
pre sha:8a967b566603225d2719735c0d27bf6c91a49bd2
author	Noel Grandin <noel.grandin@collabora.co.uk>	2022-03-23
tdf#147641 default font size for captions always reset
Comment 9 Timur 2022-05-09 10:27:23 UTC
*** Bug 147641 has been marked as a duplicate of this bug. ***