Download it now!
Bug 136104 - Sidebar: Remove Lists group in impress/draw
Summary: Sidebar: Remove Lists group in impress/draw
Status: RESOLVED DUPLICATE of bug 136075
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2020-08-25 09:58 UTC by andreas_k
Modified: 2020-09-15 22:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sidebar layout in impress when select an rechtangular (34.13 KB, image/png)
2020-08-25 09:58 UTC, andreas_k
Details
draw rectangular list section missing (35.68 KB, image/png)
2020-08-25 20:36 UTC, andreas_k
Details
chart Type sidebar layout (17.01 KB, image/png)
2020-08-28 12:47 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-08-25 09:58:00 UTC
I propose to remove the Lists Sidebar group and integrate it back to the Paragraph group like it is in writer.

In impress/draw there is a separate group with no benefit in addition that it's not consistent through all apps, the List group sometimes isn't arranged well like you see in the attachment where Lists is not after Paragraph it's after Area.
Comment 1 andreas_k 2020-08-25 09:58:26 UTC
Created attachment 164663 [details]
Sidebar layout in impress when select an rechtangular
Comment 2 m.a.riosv 2020-08-25 11:29:04 UTC
*** Bug 136103 has been marked as a duplicate of this bug. ***
Comment 3 andreas_k 2020-08-25 20:36:54 UTC
Created attachment 164683 [details]
draw rectangular list section missing

as you can see in the screenshot, the list group is missing but should be available. If there is only one paragraph group, than it's no issue.
Comment 4 andreas_k 2020-08-28 12:47:05 UTC
Created attachment 164802 [details]
chart Type sidebar layout

How the layout should look like with 3 sections in one group, I recommend the layout in Chafrt Type Group Elements with the bold headers for each section.
Comment 5 andreas_k 2020-09-08 08:19:06 UTC
the patch where it was separated

https://gerrit.libreoffice.org/c/core/+/70276
Comment 6 V Stuart Foote 2020-09-15 22:56:46 UTC

*** This bug has been marked as a duplicate of bug 136075 ***