Bug 136113 - FILEOPEN XLSX Shape editing does not change modified status of file
Summary: FILEOPEN XLSX Shape editing does not change modified status of file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:7.2.0
Keywords: bibisected, bisected, regression
: 135534 139657 (view as bug list)
Depends on:
Blocks: OOXML-Shapes ModifiedStatus
  Show dependency treegraph
 
Reported: 2020-08-25 14:47 UTC by NISZ LibreOffice Team
Modified: 2021-03-15 15:47 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the problem in Calc (182.54 KB, image/png)
2020-08-25 14:47 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-08-25 14:47:31 UTC
Created attachment 164677 [details]
Screenshot of the problem in Calc

When an XLSX file with shapes is opened in Calc (such as Attachment #164368 [details]) the shapes can be moved or recolored and the documents modified status does not change.

Steps to reproduce:
    1. Open Attachment #164368 [details]
    2. Move one of the shapes and / or change the fill color and / or delete one of them
    3. Try to close the document

Actual results:
Document is not considered modified so Calc closes it without asking about saving.

Expected results:
Document should be considered modified. Moving shapes in an ODS file correctly changes the documents modified state.

LibreOffice details:
Version: 7.1.0.0.alpha0+ (x86)
Build ID: 4f0617275f2c9669901a4b06d2133533ceb437a0
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

But not yet in:
Verzió: 6.4.0.3 (x86)
Build az.: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: alapértelmezett; VCL: win; 
Területi beállítások: en-US (hu_HU); Felület nyelve: hu-HU
Calc: CL

Additional Information: 

Bibisected using bibisect-win64-7.0 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=edf13fe1247e7ef411a9ff5435385573fad01f56 
author	Noel Grandin <noel.grandin@collabora.co.uk>	2020-03-03 09:23:30 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-03-10 09:26:19 +0100
tdf#93831 xlsx file full of pictures of numbers slow to open

Adding CC to: Noel Grandin
Comment 1 Commit Notification 2020-08-28 18:24:19 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c9b81503a85a2763e1bfd1b6722fcf6d96a983e7

tdf#136113 shape editing does not change modified status

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2020-08-29 06:28:54 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/3905cb1b2c723617298dd525cf18669f3ca5720b

tdf#136113 shape editing does not change modified status

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2020-08-31 09:05:25 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e2f4e65a7b8024c00b049eebf0d87637efda7f24
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!
Comment 4 NISZ LibreOffice Team 2020-10-06 12:01:27 UTC
*** Bug 135534 has been marked as a duplicate of this bug. ***
Comment 5 Bartek 2020-10-06 13:11:44 UTC
Tested and verified in

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: pl-PL (pl_PL); UI: pl-PL
Calc: CL

Thanks.
Comment 6 Timur 2021-03-15 08:09:49 UTC
*** Bug 139657 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2021-03-15 15:47:08 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/12d719d9dfe72f376ae0997977f44310031a45d2

tdf#136113: sc_uicalc: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.