Bug 136124 - Crash on autosave or manage changes
Summary: Crash on autosave or manage changes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Crash-BigPtrArray
  Show dependency treegraph
 
Reported: 2020-08-25 21:00 UTC by Telesto
Modified: 2021-03-29 11:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-25 21:00:17 UTC
Description:
Crash on autosave or manage changes

Steps to Reproduce:
1. Open attachment 162927 [details]
2. Tools -> Options -> Save/ load set autosave to 1 minute
3. CTRL+A
4. CTRL+X
5. Edit -> Track changes -> Manage
6. Minimize -
7. Wait -> LibreOffice starts blinking in the task bar 
8. Click it -> Crash

swlo!BigPtrArray::Index2Block+0xc8
swlo!BigPtrArray::operator[]+0x1e
swlo!SwTextNode::CalcHiddenCharFlags+0xa2
swlo!SwDoc::Spell+0x26e9


Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 8700bace8c0714d853f5df6918ab9c8bb3d81f77
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Dieter 2021-03-28 09:59:27 UTC
Telesto, it seems, that nobody could confirm this bug since more than one year. So Iā€˜d like to ask, if it is still reproducible for you. Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/current.html? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Telesto 2021-03-29 11:30:21 UTC
Gone, as with most of the other BigPtrArray bugs
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: f96004096268f5e71120678e32fc8c74055819aa
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL