Bug 136170 - user installed fonts removed and replaced when installing or upgrading LibreOffice
Summary: user installed fonts removed and replaced when installing or upgrading LibreO...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Fonts-Bundled
  Show dependency treegraph
 
Reported: 2020-08-27 08:07 UTC by Brian Inglis
Modified: 2020-08-31 14:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Inglis 2020-08-27 08:07:54 UTC
Description:
When installing/upgrading LibreOffice my terminal, editor, and browser windows changed fonts and sizes and eventually became unresponsive, and not startable, as the LibreOffice installation has removed my personally selected, installed, and configured default fonts DejaVu, and possibly others I have installed. 
I have a number of Unicode fonts installed with large glyph repertoires from various sources, some updating those originally distributed with glyphs in newer Unicode releases from reliable font sources. 
Please do not replace any fonts you have not previously installed, unless they are identical (size and date and sha512sum) to one you previously distributed, and your installation is providing a newer and better font in the upgrade, as those we installed may be newer and better or different than those you distribute. 

Steps to Reproduce:
1. Install DejaVu fonts.
2. Configure DejaVu fonts as defaults in terminals, editors, browsers.
3. Install or upgrade LibreOffice.

Actual Results:
Fonts removed, then reinstalled after reboot.

Expected Results:
Fonts left alone if they were already present, not from LibreOffice installation, similar to how /etc/progrc upgrades are applied only if the file is as originally distributed (size, date, shasum), not if locally modified or installed.


Reproducible: Always


User Profile Reset: No



Additional Info:
Latest upgrade was actually to Version 6.4.6.2 (not available in version drop down) but also happened on at least the previous upgrade to 6.4.5.2 and possibly earlier. 
Modern installers do not normally replace pre-existing system components or files nor downgrade them if they are already in place, so normally have no reason to require a system reboot, unless the product itself is being executed during an upgrade, so should be prompted to be exited or exited automatically by the installer.
You have added "Font Hell!" to Windows previous "DLL Hell!" ;^>
Comment 1 Telesto 2020-08-28 07:44:09 UTC
@Mike
You might be interested in this one
Comment 2 Mike Kaganski 2020-08-28 07:51:05 UTC
It should not be "fixed" in any way. Our installer lists fonts that we need to install. They are all versioned. The installer just tells Windows Installer service its information, and the system service decides if the resources existing/missing need updating/installing.

If some resource already present on system is unversioned, or has version lower than that in installer package, it will be updated. That is normal and OK. If a user wants to create something like personal tweaked fonts, the user is free to make their versions arbitrarily high, to prevent their upgrade..
Comment 3 Mike Kaganski 2020-08-28 07:53:50 UTC
And the question is why we bundle fonts that are NOT required to LibreOffice functioning at all - see bug 91886 comment 9.
Comment 4 Brian Inglis 2020-08-30 07:53:18 UTC
@Mike 
Most of your fonts are *NOT* versioned in a manner that Windows recognizes: only 18 of your 58 fonts (174 font files total) seem to have visible Windows versions, possibly because that property is not identical across all files e.g. Liberations Sans 2.00.3 includes Liberation Sans Narrow 1.07.5? 
All 174 files, seem to be removed and replaced with every recent upgrade, if I can believe the Windows birth dates, including DejaVu, Linux, Adobe, and SIL fonts, all of which I already have installed with the most recent versions I can find from selected sources, often GitHub. 
For example, LO includes Liberation Sans Narrow 1.07.5, SIL has had 1.07.6 available on GitHub since 2018-11-13, so you replace my newer versions with your older versions, and remove and replace my DejaVu 2.37 with your DejaVu 2.37, possibly because LO and/or Windows installer does not know about or use font versions? 

Installed font documentation: 
https://wiki.documentfoundation.org/Fonts#List_of_fonts_in_LibreOffice
is out of date, incomplete, and information about those on Windows is useless, as they are all installed in the system /Windows/Fonts/ folder, so unless you use other utilities to determine what was added when, or already know what they are, you can't tell if they were replaced. 

So not only do I have to suffer the *Font HELL* of removing *Installed* fonts which I have as defaults in apps that allow such selections, somehow effectively disabling some of those apps until I reboot, I then also have to replace those you removed so that I get back those from sources I prefer, as I know those are the latest up to date versions available.
Comment 5 Mike Kaganski 2020-08-31 06:10:05 UTC
(In reply to Brian Inglis from comment #4)
> Most of your fonts are *NOT* versioned in a manner that Windows recognizes:
> only 18 of your 58 fonts (174 font files total) seem to have visible Windows
> versions, possibly because that property is not identical across all files
> e.g. Liberations Sans 2.00.3 includes Liberation Sans Narrow 1.07.5? 

If you open a LibreOffice MSI, you may inspect the Files table and see yourself. E.g., here's the full list for TTFs in the said table in LibreOffice_7.0.1.1_Win_x64.msi:

> File	Component	FileName	FileSize	Version	Language	Attributes	Sequence
> 
> opens___.ttf	auto_ooo_fonts_pkg_extras_fonts__libreoffice_share_fonts_truetype	opens___.ttf	207544	102.11.0.0		16384	88
> Alef_Bold.ttf	auto_ooo_fonts_pkg_fonts_alef__libreoffice_share_fonts_truetype	ALEF-B~1.TTF|Alef-Bold.ttf	92660	1.1.0.0		16384	89
> Alef_Regular.ttf	auto_ooo_fonts_pkg_fonts_alef__libreoffice_share_fonts_truetype	ALEF-R~1.TTF|Alef-Regular.ttf	91360	1.1.0.0		16384	90
> Amiri_Bold.ttf	auto_ooo_fonts_pkg_fonts_amiri__libreoffice_share_fonts_truetype	AMIRI-~1.TTF|Amiri-Bold.ttf	531868	0.111.0.0		16384	91
> Amiri_BoldSlanted.ttf	auto_ooo_fonts_pkg_fonts_amiri__libreoffice_share_fonts_truetype	AMIRI-~2.TTF|Amiri-BoldSlanted.ttf	532576	0.111.0.0		16384	92
> Amiri_Regular.ttf	auto_ooo_fonts_pkg_fonts_amiri__libreoffice_share_fonts_truetype	AMIRI-~3.TTF|Amiri-Regular.ttf	551560	0.111.0.0		16384	93
> Amiri_Slanted.ttf	auto_ooo_fonts_pkg_fonts_amiri__libreoffice_share_fonts_truetype	AMIRI-~4.TTF|Amiri-Slanted.ttf	537496	0.111.0.0		16384	94
> AmiriQuran.ttf	auto_ooo_fonts_pkg_fonts_amiri__libreoffice_share_fonts_truetype	AMIRIQ~1.TTF|AmiriQuran.ttf	136300	0.111.0.0		16384	95
> Caladea_Bold.ttf	auto_ooo_fonts_pkg_fonts_caladea__libreoffice_share_fonts_truetype	CALADE~1.TTF|Caladea-Bold.ttf	58892	1.2.0.0		16384	96
> Caladea_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_caladea__libreoffice_share_fonts_truetype	CALADE~2.TTF|Caladea-BoldItalic.ttf	61828	1.2.0.0		16384	97
> Caladea_Italic.ttf	auto_ooo_fonts_pkg_fonts_caladea__libreoffice_share_fonts_truetype	CALADE~3.TTF|Caladea-Italic.ttf	61860	1.2.0.0		16384	98
> Caladea_Regular.ttf	auto_ooo_fonts_pkg_fonts_caladea__libreoffice_share_fonts_truetype	CALADE~4.TTF|Caladea-Regular.ttf	58964	1.2.0.0		16384	99
> Carlito_Bold.ttf	auto_ooo_fonts_pkg_fonts_carlito__libreoffice_share_fonts_truetype	CARLIT~1.TTF|Carlito-Bold.ttf	690516	1.103.0.0		16384	100
> Carlito_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_carlito__libreoffice_share_fonts_truetype	CARLIT~2.TTF|Carlito-BoldItalic.ttf	816716	1.103.0.0		16384	101
> Carlito_Italic.ttf	auto_ooo_fonts_pkg_fonts_carlito__libreoffice_share_fonts_truetype	CARLIT~3.TTF|Carlito-Italic.ttf	623416	1.103.0.0		16384	102
> Carlito_Regular.ttf	auto_ooo_fonts_pkg_fonts_carlito__libreoffice_share_fonts_truetype	CARLIT~4.TTF|Carlito-Regular.ttf	635996	1.103.0.0		16384	103
> DavidCLM_Bold.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	DAVIDC~1.TTF|DavidCLM-Bold.ttf	24284	0.120.0.0		16384	104
> DavidCLM_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	DAVIDC~2.TTF|DavidCLM-BoldItalic.ttf	26148	0.120.0.0		16384	105
> DavidCLM_Medium.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	DAVIDC~3.TTF|DavidCLM-Medium.ttf	24608	0.120.0.0		16384	106
> DavidCLM_MediumItalic.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	DAVIDC~4.TTF|DavidCLM-MediumItalic.ttf	26640	0.120.0.0		16384	107
> FrankRuehlCLM_Bold.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	FRANKR~1.TTF|FrankRuehlCLM-Bold.ttf	45056	0.121.0.0		16384	108
> FrankRuehlCLM_BoldOblique.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	FRANKR~2.TTF|FrankRuehlCLM-BoldOblique.ttf	48820	0.121.0.0		16384	109
> FrankRuehlCLM_Medium.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	FRANKR~3.TTF|FrankRuehlCLM-Medium.ttf	43904	0.121.0.0		16384	110
> FrankRuehlCLM_MediumOblique.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	FRANKR~4.TTF|FrankRuehlCLM-MediumOblique.ttf	46740	0.121.0.0		16384	111
> MiriamCLM_Bold.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	MIRIAM~1.TTF|MiriamCLM-Bold.ttf	20844	0.120.0.0		16384	112
> MiriamCLM_Book.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	MIRIAM~2.TTF|MiriamCLM-Book.ttf	20868	0.120.0.0		16384	113
> MiriamMonoCLM_Bold.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	MIRIAM~3.TTF|MiriamMonoCLM-Bold.ttf	34000	0.120.0.0		16384	114
> MiriamMonoCLM_BoldOblique.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	MIRIAM~4.TTF|MiriamMonoCLM-BoldOblique.ttf	36732	0.120.0.0		16384	115
> MiriamMonoCLM_Book.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	MIRIAM~5.TTF|MiriamMonoCLM-Book.ttf	31172	0.120.0.0		16384	116
> MiriamMonoCLM_BookOblique.ttf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	MIRIAM~6.TTF|MiriamMonoCLM-BookOblique.ttf	34052	0.120.0.0		16384	117
> NachlieliCLM_Bold.otf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	NACHLI~1.OTF|NachlieliCLM-Bold.otf	38672	0.131.0.0		16384	118
> NachlieliCLM_BoldOblique.otf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	NACHLI~2.OTF|NachlieliCLM-BoldOblique.otf	54104	0.131.0.0		16384	119
> NachlieliCLM_Light.otf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	NACHLI~3.OTF|NachlieliCLM-Light.otf	28476	0.131.0.0		16384	120
> NachlieliCLM_LightOblique.otf	auto_ooo_fonts_pkg_fonts_culmus__libreoffice_share_fonts_truetype	NACHLI~4.OTF|NachlieliCLM-LightOblique.otf	49076	0.131.0.0		16384	121
> DejaVuMathTeXGyre.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~1.TTF|DejaVuMathTeXGyre.ttf	577708	2.37.0.0		16384	122
> DejaVuSans_Bold.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~2.TTF|DejaVuSans-Bold.ttf	705684	2.37.0.0		16384	123
> DejaVuSans_BoldOblique.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~3.TTF|DejaVuSans-BoldOblique.ttf	643292	2.37.0.0		16384	124
> DejaVuSans_ExtraLight.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~4.TTF|DejaVuSans-ExtraLight.ttf	355380	2.37.0.0		16384	125
> DejaVuSans_Oblique.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~5.TTF|DejaVuSans-Oblique.ttf	635416	2.37.0.0		16384	126
> DejaVuSans.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~6.TTF|DejaVuSans.ttf	757076	2.37.0.0		16384	127
> DejaVuSansCondensed_Bold.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~7.TTF|DejaVuSansCondensed-Bold.ttf	665028	2.37.0.0		16384	128
> DejaVuSansCondensed_BoldOblique.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~8.TTF|DejaVuSansCondensed-BoldOblique.ttf	611836	2.37.0.0		16384	129
> DejaVuSansCondensed_Oblique.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAVU~9.TTF|DejaVuSansCondensed-Oblique.ttf	599292	2.37.0.0		16384	130
> DejaVuSansCondensed.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~1.TTF|DejaVuSansCondensed.ttf	680264	2.37.0.0		16384	131
> DejaVuSansMono_Bold.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~2.TTF|DejaVuSansMono-Bold.ttf	331992	2.37.0.0		16384	132
> DejaVuSansMono_BoldOblique.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~3.TTF|DejaVuSansMono-BoldOblique.ttf	253580	2.37.0.0		16384	133
> DejaVuSansMono_Oblique.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~4.TTF|DejaVuSansMono-Oblique.ttf	251932	2.37.0.0		16384	134
> DejaVuSansMono.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~5.TTF|DejaVuSansMono.ttf	340712	2.37.0.0		16384	135
> DejaVuSerif_Bold.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~6.TTF|DejaVuSerif-Bold.ttf	356088	2.37.0.0		16384	136
> DejaVuSerif_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~7.TTF|DejaVuSerif-BoldItalic.ttf	347460	2.37.0.0		16384	137
> DejaVuSerif_Italic.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~8.TTF|DejaVuSerif-Italic.ttf	345996	2.37.0.0		16384	138
> DejaVuSerif.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~9.TTF|DejaVuSerif.ttf	380132	2.37.0.0		16384	139
> DejaVuSerifCondensed_Bold.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~10.TTF|DejaVuSerifCondensed-Bold.ttf	331244	2.37.0.0		16384	140
> DejaVuSerifCondensed_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~11.TTF|DejaVuSerifCondensed-BoldItalic.ttf	346508	2.37.0.0		16384	141
> DejaVuSerifCondensed_Italic.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~12.TTF|DejaVuSerifCondensed-Italic.ttf	345324	2.37.0.0		16384	142
> DejaVuSerifCondensed.ttf	auto_ooo_fonts_pkg_fonts_dejavu__libreoffice_share_fonts_truetype	DEJAV~13.TTF|DejaVuSerifCondensed.ttf	346664	2.37.0.0		16384	143
> EmojiOneColor_SVGinOT.ttf	auto_ooo_fonts_pkg_fonts_emojione_color__libreoffice_share_f_e9fd09007	EMOJIO~1.TTF|EmojiOneColor-SVGinOT.ttf	6193636	1.3.0.0		16384	144
> GenBasB.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GenBasB.ttf	266840	1.102.0.0		16384	145
> GenBasBI.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GenBasBI.ttf	245852	1.102.0.0		16384	146
> GenBasI.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GenBasI.ttf	258680	1.102.0.0		16384	147
> GenBasR.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GenBasR.ttf	264216	1.102.0.0		16384	148
> GenBkBasB.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GENBKB~1.TTF|GenBkBasB.ttf	267024	1.102.0.0		16384	149
> GenBkBasBI.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GENBKB~2.TTF|GenBkBasBI.ttf	245096	1.102.0.0		16384	150
> GenBkBasI.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GENBKB~3.TTF|GenBkBasI.ttf	261328	1.102.0.0		16384	151
> GenBkBasR.ttf	auto_ooo_fonts_pkg_fonts_gentium__libreoffice_share_fonts_truetype	GENBKB~4.TTF|GenBkBasR.ttf	267604	1.102.0.0		16384	152
> KacstBook.ttf	auto_ooo_fonts_pkg_fonts_kacst__libreoffice_share_fonts_truetype	KACSTB~1.TTF|KacstBook.ttf	63100	2.1.0.0		16384	153
> KacstOffice.ttf	auto_ooo_fonts_pkg_fonts_kacst__libreoffice_share_fonts_truetype	KACSTO~1.TTF|KacstOffice.ttf	73680	2.1.0.0		16384	154
> LiberationMono_Bold.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~1.TTF|LiberationMono-Bold.ttf	301844	2.0.3.0		16384	155
> LiberationMono_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~2.TTF|LiberationMono-BoldItalic.ttf	278184	2.0.3.0		16384	156
> LiberationMono_Italic.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~3.TTF|LiberationMono-Italic.ttf	275244	2.0.3.0		16384	157
> LiberationMono_Regular.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~4.TTF|LiberationMono-Regular.ttf	313560	2.0.3.0		16384	158
> LiberationSans_Bold.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~5.TTF|LiberationSans-Bold.ttf	411344	2.0.3.0		16384	159
> LiberationSans_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~6.TTF|LiberationSans-BoldItalic.ttf	407200	2.0.3.0		16384	160
> LiberationSans_Italic.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~7.TTF|LiberationSans-Italic.ttf	413108	2.0.3.0		16384	161
> LiberationSans_Regular.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~8.TTF|LiberationSans-Regular.ttf	407860	2.0.3.0		16384	162
> LiberationSerif_Bold.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBERA~9.TTF|LiberationSerif-Bold.ttf	365292	2.0.3.0		16384	163
> LiberationSerif_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBER~1.TTF|LiberationSerif-BoldItalic.ttf	371292	2.0.3.0		16384	164
> LiberationSerif_Italic.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBER~2.TTF|LiberationSerif-Italic.ttf	371200	2.0.3.0		16384	165
> LiberationSerif_Regular.ttf	auto_ooo_fonts_pkg_fonts_liberation__libreoffice_share_fonts_truetype	LIBER~3.TTF|LiberationSerif-Regular.ttf	388528	2.0.3.0		16384	166
> LiberationSansNarrow_Bold.ttf	auto_ooo_fonts_pkg_fonts_liberation_narrow__libreoffice_shar_6d3da9271	LIBER~4.TTF|LiberationSansNarrow-Bold.ttf	110260	1.7.5.0		16384	167
> LiberationSansNarrow_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_liberation_narrow__libreoffice_shar_6d3da9271	LIBER~5.TTF|LiberationSansNarrow-BoldItalic.ttf	128476	1.7.5.0		16384	168
> LiberationSansNarrow_Italic.ttf	auto_ooo_fonts_pkg_fonts_liberation_narrow__libreoffice_shar_6d3da9271	LIBER~6.TTF|LiberationSansNarrow-Italic.ttf	132460	1.7.5.0		16384	169
> LiberationSansNarrow_Regular.ttf	auto_ooo_fonts_pkg_fonts_liberation_narrow__libreoffice_shar_6d3da9271	LIBER~7.TTF|LiberationSansNarrow-Regular.ttf	113036	1.7.5.0		16384	170
> LinBiolinum_RB_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINBIO~1.TTF|LinBiolinum_RB_G.ttf	1988092	1.1.0.0		16384	171
> LinBiolinum_RI_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINBIO~2.TTF|LinBiolinum_RI_G.ttf	2001216	1.1.0.0		16384	172
> LinBiolinum_R_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINBIO~3.TTF|LinBiolinum_R_G.ttf	1937644	1.1.0.0		16384	173
> LinLibertine_DR_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINLIB~1.TTF|LinLibertine_DR_G.ttf	2007364	5.0.9.0		16384	174
> LinLibertine_RBI_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINLIB~2.TTF|LinLibertine_RBI_G.ttf	1578296	5.1.3.0		16384	175
> LinLibertine_RB_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINLIB~3.TTF|LinLibertine_RB_G.ttf	2105948	5.0.3.0		16384	176
> LinLibertine_RI_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINLIB~4.TTF|LinLibertine_RI_G.ttf	2050040	5.1.3.0		16384	177
> LinLibertine_RZI_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINLIB~5.TTF|LinLibertine_RZI_G.ttf	1955464	5.1.1.0		16384	178
> LinLibertine_RZ_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINLIB~6.TTF|LinLibertine_RZ_G.ttf	1972756	5.1.1.0		16384	179
> LinLibertine_R_G.ttf	auto_ooo_fonts_pkg_fonts_libertineg__libreoffice_share_fonts_truetype	LINLIB~7.TTF|LinLibertine_R_G.ttf	2567492	5.1.3.0		16384	180
> DavidLibre_Bold.ttf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	DAVIDL~1.TTF|DavidLibre-Bold.ttf	121848	1.2.0.0		16384	181
> DavidLibre_Regular.ttf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	DAVIDL~2.TTF|DavidLibre-Regular.ttf	116676	1.2.0.0		16384	182
> FrankRuhlHofshi_Bold.otf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	FRANKR~5.OTF|FrankRuhlHofshi-Bold.otf	61952	5.1.0.0		16384	183
> FrankRuhlHofshi_Regular.otf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	FRANKR~6.OTF|FrankRuhlHofshi-Regular.otf	61680	5.1.0.0		16384	184
> MiriamLibre_Bold.otf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	MIRIAM~7.OTF|MiriamLibre-Bold.otf	65920	1.0.0.0		16384	185
> MiriamLibre_Regular.otf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	MIRIAM~8.OTF|MiriamLibre-Regular.otf	64252	1.0.0.0		16384	186
> Rubik_Bold.ttf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	RUBIK-~1.TTF|Rubik-Bold.ttf	140396	1.100.0.0		16384	187
> Rubik_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	RUBIK-~2.TTF|Rubik-BoldItalic.ttf	146128	1.100.0.0		16384	188
> Rubik_Italic.ttf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	RUBIK-~3.TTF|Rubik-Italic.ttf	143392	1.100.0.0		16384	189
> Rubik_Regular.ttf	auto_ooo_fonts_pkg_fonts_libre_hebrew__libreoffice_share_fon_d263cce89	RUBIK-~4.TTF|Rubik-Regular.ttf	136624	1.100.0.0		16384	190
> NotoKufiArabic_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOKU~1.TTF|NotoKufiArabic-Bold.ttf	80472	1.4.0.0		16384	191
> NotoKufiArabic_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOKU~2.TTF|NotoKufiArabic-Regular.ttf	80440	1.4.0.0		16384	192
> NotoMono_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOMO~1.TTF|NotoMono-Regular.ttf	107848	1.0.0.0		16384	193
> NotoNaskhArabic_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTONA~1.TTF|NotoNaskhArabic-Bold.ttf	224128	1.6.0.0		16384	194
> NotoNaskhArabic_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTONA~2.TTF|NotoNaskhArabic-Regular.ttf	255280	1.7.0.0		16384	195
> NotoNaskhArabicUI_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTONA~3.TTF|NotoNaskhArabicUI-Bold.ttf	241108	1.7.0.0		16384	196
> NotoNaskhArabicUI_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTONA~4.TTF|NotoNaskhArabicUI-Regular.ttf	256116	1.7.0.0		16384	197
> NotoSans_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~1.TTF|NotoSans-Bold.ttf	455164	2.0.0.0		16384	198
> NotoSans_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~2.TTF|NotoSans-BoldItalic.ttf	471004	2.0.0.0		16384	199
> NotoSans_Condensed.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~3.TTF|NotoSans-Condensed.ttf	450924	2.0.0.0		16384	200
> NotoSans_CondensedBold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~4.TTF|NotoSans-CondensedBold.ttf	455020	2.0.0.0		16384	201
> NotoSans_CondensedBoldItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~5.TTF|NotoSans-CondensedBoldItalic.ttf	474308	2.0.0.0		16384	202
> NotoSans_CondensedItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~6.TTF|NotoSans-CondensedItalic.ttf	472532	2.0.0.0		16384	203
> NotoSans_Italic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~7.TTF|NotoSans-Italic.ttf	470472	2.0.0.0		16384	204
> NotoSans_Light.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~8.TTF|NotoSans-Light.ttf	443040	2.0.0.0		16384	205
> NotoSans_LightItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSA~9.TTF|NotoSans-LightItalic.ttf	463608	2.0.0.0		16384	206
> NotoSans_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~1.TTF|NotoSans-Regular.ttf	455188	2.0.0.0		16384	207
> NotoSansArabic_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~2.TTF|NotoSansArabic-Bold.ttf	199392	2.0.0.0		16384	208
> NotoSansArabic_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~3.TTF|NotoSansArabic-Regular.ttf	187000	2.0.0.0		16384	209
> NotoSansArabicUI_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~4.TTF|NotoSansArabicUI-Bold.ttf	199984	2.0.0.0		16384	210
> NotoSansArabicUI_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~5.TTF|NotoSansArabicUI-Regular.ttf	187524	2.0.0.0		16384	211
> NotoSansArmenian_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~6.TTF|NotoSansArmenian-Bold.ttf	29548	2.40.0.0		16384	212
> NotoSansArmenian_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~7.TTF|NotoSansArmenian-Regular.ttf	29588	2.40.0.0		16384	213
> NotoSansGeorgian_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~8.TTF|NotoSansGeorgian-Bold.ttf	42856	2.0.0.0		16384	214
> NotoSansGeorgian_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~9.TTF|NotoSansGeorgian-Regular.ttf	41656	2.0.0.0		16384	215
> NotoSansHebrew_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~10.TTF|NotoSansHebrew-Bold.ttf	28008	2.0.0.0		16384	216
> NotoSansHebrew_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~11.TTF|NotoSansHebrew-Regular.ttf	27696	2.0.0.0		16384	217
> NotoSansLao_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~12.TTF|NotoSansLao-Bold.ttf	32704	2.0.0.0		16384	218
> NotoSansLao_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~13.TTF|NotoSansLao-Regular.ttf	31424	2.0.0.0		16384	219
> NotoSansLisu_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~14.TTF|NotoSansLisu-Regular.ttf	13184	2.0.0.0		16384	220
> NotoSerif_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~1.TTF|NotoSerif-Bold.ttf	570708	2.0.0.0		16384	221
> NotoSerif_BoldItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~2.TTF|NotoSerif-BoldItalic.ttf	608488	2.0.0.0		16384	222
> NotoSerif_Condensed.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~3.TTF|NotoSerif-Condensed.ttf	560884	2.0.0.0		16384	223
> NotoSerif_CondensedBold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~4.TTF|NotoSerif-CondensedBold.ttf	580856	2.0.0.0		16384	224
> NotoSerif_CondensedBoldItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~5.TTF|NotoSerif-CondensedBoldItalic.ttf	609676	2.0.0.0		16384	225
> NotoSerif_CondensedItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~6.TTF|NotoSerif-CondensedItalic.ttf	588368	2.0.0.0		16384	226
> NotoSerif_Italic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~7.TTF|NotoSerif-Italic.ttf	593748	2.0.0.0		16384	227
> NotoSerif_Light.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~8.TTF|NotoSerif-Light.ttf	564772	2.0.0.0		16384	228
> NotoSerif_LightItalic.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOSE~9.TTF|NotoSerif-LightItalic.ttf	578480	2.0.0.0		16384	229
> NotoSerif_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~15.TTF|NotoSerif-Regular.ttf	552144	2.0.0.0		16384	230
> NotoSerifArmenian_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~16.TTF|NotoSerifArmenian-Bold.ttf	29212	2.40.0.0		16384	231
> NotoSerifArmenian_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~17.TTF|NotoSerifArmenian-Regular.ttf	29984	2.40.0.0		16384	232
> NotoSerifGeorgian_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~18.TTF|NotoSerifGeorgian-Bold.ttf	49880	2.0.0.0		16384	233
> NotoSerifGeorgian_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~19.TTF|NotoSerifGeorgian-Regular.ttf	47484	2.0.0.0		16384	234
> NotoSerifHebrew_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~20.TTF|NotoSerifHebrew-Bold.ttf	33656	2.0.0.0		16384	235
> NotoSerifHebrew_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~21.TTF|NotoSerifHebrew-Regular.ttf	33208	2.0.0.0		16384	236
> NotoSerifLao_Bold.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~22.TTF|NotoSerifLao-Bold.ttf	40668	2.0.0.0		16384	237
> NotoSerifLao_Regular.ttf	auto_ooo_fonts_pkg_fonts_noto__libreoffice_share_fonts_truetype	NOTOS~23.TTF|NotoSerifLao-Regular.ttf	38796	2.0.0.0		16384	238
> ReemKufi_Regular.ttf	auto_ooo_fonts_pkg_fonts_reem__libreoffice_share_fonts_truetype	REEMKU~1.TTF|ReemKufi-Regular.ttf	83072	0.7.0.0		16384	239
> Scheherazade_Bold.ttf	auto_ooo_fonts_pkg_fonts_scheherazade__libreoffice_share_fon_a8147fb12	SCHEHE~1.TTF|Scheherazade-Bold.ttf	547772	2.100.0.0		16384	240
> Scheherazade_Regular.ttf	auto_ooo_fonts_pkg_fonts_scheherazade__libreoffice_share_fon_a8147fb12	SCHEHE~2.TTF|Scheherazade-Regular.ttf	500396	2.100.0.0		16384	241
> SourceCodePro_Black.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~1.TTF|SourceCodePro-Black.ttf	211460	2.30.0.0		16384	242
> SourceCodePro_BlackIt.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~2.TTF|SourceCodePro-BlackIt.ttf	174208	1.50.0.0		16384	243
> SourceCodePro_Bold.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~3.TTF|SourceCodePro-Bold.ttf	211716	2.30.0.0		16384	244
> SourceCodePro_BoldIt.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~4.TTF|SourceCodePro-BoldIt.ttf	174372	1.50.0.0		16384	245
> SourceCodePro_ExtraLight.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~5.TTF|SourceCodePro-ExtraLight.ttf	213512	2.30.0.0		16384	246
> SourceCodePro_ExtraLightIt.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~6.TTF|SourceCodePro-ExtraLightIt.ttf	176076	1.50.0.0		16384	247
> SourceCodePro_It.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~7.TTF|SourceCodePro-It.ttf	180472	1.50.0.0		16384	248
> SourceCodePro_Light.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~8.TTF|SourceCodePro-Light.ttf	213252	2.30.0.0		16384	249
> SourceCodePro_LightIt.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURCE~9.TTF|SourceCodePro-LightIt.ttf	176124	1.50.0.0		16384	250
> SourceCodePro_Medium.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURC~1.TTF|SourceCodePro-Medium.ttf	212160	2.30.0.0		16384	251
> SourceCodePro_MediumIt.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURC~2.TTF|SourceCodePro-MediumIt.ttf	175308	1.50.0.0		16384	252
> SourceCodePro_Regular.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURC~3.TTF|SourceCodePro-Regular.ttf	212880	2.30.0.0		16384	253
> SourceCodePro_Semibold.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURC~4.TTF|SourceCodePro-Semibold.ttf	212048	2.30.0.0		16384	254
> SourceCodePro_SemiboldIt.ttf	auto_ooo_fonts_pkg_fonts_sourcecode__libreoffice_share_fonts_truetype	SOURC~5.TTF|SourceCodePro-SemiboldIt.ttf	174764	1.50.0.0		16384	255
> SourceSansPro_Black.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~6.TTF|SourceSansPro-Black.ttf	289528	2.10.0.0		16384	256
> SourceSansPro_BlackIt.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~7.TTF|SourceSansPro-BlackIt.ttf	102756	1.65.0.0		16384	257
> SourceSansPro_Bold.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~8.TTF|SourceSansPro-Bold.ttf	291584	2.10.0.0		16384	258
> SourceSansPro_BoldIt.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~9.TTF|SourceSansPro-BoldIt.ttf	103008	1.65.0.0		16384	259
> SourceSansPro_ExtraLight.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~10.TTF|SourceSansPro-ExtraLight.ttf	291648	2.10.0.0		16384	260
> SourceSansPro_ExtraLightIt.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~11.TTF|SourceSansPro-ExtraLightIt.ttf	104124	1.65.0.0		16384	261
> SourceSansPro_It.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~12.TTF|SourceSansPro-It.ttf	103620	1.65.0.0		16384	262
> SourceSansPro_Light.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~13.TTF|SourceSansPro-Light.ttf	293304	2.10.0.0		16384	263
> SourceSansPro_LightIt.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~14.TTF|SourceSansPro-LightIt.ttf	103996	1.65.0.0		16384	264
> SourceSansPro_Regular.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~15.TTF|SourceSansPro-Regular.ttf	293960	2.10.0.0		16384	265
> SourceSansPro_Semibold.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~16.TTF|SourceSansPro-Semibold.ttf	292456	2.10.0.0		16384	266
> SourceSansPro_SemiboldIt.ttf	auto_ooo_fonts_pkg_fonts_sourcesans__libreoffice_share_fonts_truetype	SOURC~17.TTF|SourceSansPro-SemiboldIt.ttf	103336	1.65.0.0		16384	267
> SourceSerifPro_Black.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~18.TTF|SourceSerifPro-Black.ttf	232892	3.0.0.0		16384	268
> SourceSerifPro_BlackIt.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~19.TTF|SourceSerifPro-BlackIt.ttf	173248	3.0.0.0		16384	269
> SourceSerifPro_Bold.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~20.TTF|SourceSerifPro-Bold.ttf	233952	3.0.0.0		16384	270
> SourceSerifPro_BoldIt.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~21.TTF|SourceSerifPro-BoldIt.ttf	176332	3.0.0.0		16384	271
> SourceSerifPro_ExtraLight.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~22.TTF|SourceSerifPro-ExtraLight.ttf	227584	3.0.0.0		16384	272
> SourceSerifPro_ExtraLightIt.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~23.TTF|SourceSerifPro-ExtraLightIt.ttf	171652	3.0.0.0		16384	273
> SourceSerifPro_It.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~24.TTF|SourceSerifPro-It.ttf	173152	3.0.0.0		16384	274
> SourceSerifPro_Light.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~25.TTF|SourceSerifPro-Light.ttf	231604	3.0.0.0		16384	275
> SourceSerifPro_LightIt.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~26.TTF|SourceSerifPro-LightIt.ttf	175076	3.0.0.0		16384	276
> SourceSerifPro_Regular.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~27.TTF|SourceSerifPro-Regular.ttf	231036	3.0.0.0		16384	277
> SourceSerifPro_Semibold.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~28.TTF|SourceSerifPro-Semibold.ttf	233808	3.0.0.0		16384	278
> SourceSerifPro_SemiboldIt.ttf	auto_ooo_fonts_pkg_fonts_sourceserif__libreoffice_share_fonts_truetype	SOURC~29.TTF|SourceSerifPro-SemiboldIt.ttf	176412	3.0.0.0		16384	279

> All 174 files, seem to be removed and replaced with every recent upgrade, if
> I can believe the Windows birth dates, including DejaVu, Linux, Adobe, and
> SIL fonts, all of which I already have installed with the most recent
> versions I can find from selected sources, often GitHub. 
> For example, LO includes Liberation Sans Narrow 1.07.5, SIL has had 1.07.6
> available on GitHub since 2018-11-13, so you replace my newer versions with
> your older versions, and remove and replace my DejaVu 2.37 with your DejaVu
> 2.37, possibly because LO and/or Windows installer does not know about or
> use font versions? 

Windows knows about font versions. But *likely* Windows doesn't increase use count for fonts when user installs a font manually, and no other application installs the fonts itself... which might result in the following scenario:

1. LibreOffice installs font A.ttf version 1.0.0.0. That creates a registry record for that font in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs, with Data (ref count) equal to 1.

2. User updates the font A.ttf with version 2.0.0.0. This does not increase respective Data (ref count) under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs, so it stays 1.

3. User upgrades LibreOffice. LibreOffice uses two-staged upgrade process (see tdf#117492), i.e. it uninstalls current version first, then installs new version. During uninstall (first stage), system Installer service decreases ref count of files, and removes all components that have updated ref count equal to 0. So the font A.ttf gets removed. Then it gets installed anew from MSI package, version 1.0.0.0 (as the package contains), because there's already no file in Windows\Fonts with a newer version.

> Installed font documentation: 
> https://wiki.documentfoundation.org/Fonts#List_of_fonts_in_LibreOffice
> is out of date, incomplete, and information about those on Windows is
> useless, as they are all installed in the system /Windows/Fonts/ folder, so
> unless you use other utilities to determine what was added when, or already
> know what they are, you can't tell if they were replaced. 

You are welcome to update the wiki. Thanks.

> So not only do I have to suffer the *Font HELL* of removing *Installed*
> fonts which I have as defaults in apps that allow such selections, somehow
> effectively disabling some of those apps until I reboot, I then also have to
> replace those you removed so that I get back those from sources I prefer, as
> I know those are the latest up to date versions available.

Still there's nothing to fix in this bug. The issues here are related to different bugs. We should definitely *NOT* include unneeded fonts in out package - LibreOffice is not a font distribution technology/platform - only required fonts (used resources) need to be bundled. And a major change in the installer is required to avoid the uninstallation phase in the beginning of the upgrade.

As a workaround, I can only suggest to increase Data for the fonts under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs manually.
Comment 6 Telesto 2020-08-31 07:04:23 UTC
Adding UX only to read up the info here..related to bug 91886
Comment 7 Brian Inglis 2020-08-31 13:26:35 UTC
Thanks for that explanation, it clears up some matters with LO installation and Windows. 
Using 7z as viewer, it appears that 192 font files are supplied, so 18 of them may not be removed and replaced, and registry shows that LO registers only 20 of the font files installed, so presumably the 18 not reinstalled are among these:
```
C:\Windows\Fonts\SourceCodePro-Black.ttf (REG_DWORD) = 0x00000002 (2)
C:\Windows\Fonts\LiberationMono-Bold.ttf (REG_DWORD) = 0x00000002 (2)
C:\Windows\Fonts\Caladea-Bold.ttf (REG_DWORD) = 0x00000002 (2)
C:\Windows\Fonts\SourceSerifPro-Black.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\SourceSansPro-Black.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\NotoKufiArabic-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\Amiri-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\DejaVuMathTeXGyre.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\opens___.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\DavidCLM-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\Scheherazade-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\EmojiOneColor-SVGinOT.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\ReemKufi-Regular.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\Carlito-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\Alef-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\LinBiolinum_RB_G.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\KacstBook.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\DavidLibre-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\LiberationSansNarrow-Bold.ttf (REG_DWORD) = 0x00000001 (1)
C:\Windows\Fonts\GenBasB.ttf (REG_DWORD) = 0x00000001 (1)
```
and that your comments about ref counts are mainly correct, although 3 of the fonts appear to already have a ref count. 
That lack of registration and ref counts may also imply that the other 172 fonts may not be essential, perhaps included as template package dependencies, in which case it would be more sociable to not install them if already installed.
Comment 8 Mike Kaganski 2020-08-31 14:03:25 UTC
Hmm, I see now that only part of the fonts get registered under SharedDLLs ... and they are only those fonts that happen to be KeyPath of respective Component. Looks like we need to make each TTF an own Component.
Comment 9 Brian Inglis 2020-08-31 14:26:06 UTC
As suggested will add basic additional font info to wiki page referenced above under Blocks [Bug 113305](https://bugs.documentfoundation.org/show_bug.cgi?id=113305) [Fonts](https://wiki.documentfoundation.org/Fonts) as added to LO 6 and someone with knowledge of more detailed info can correct or update.