Bug 136191 - FILEOPEN PPTX: pie chart much smaller in Impress than Office 365
Summary: FILEOPEN PPTX: pie chart much smaller in Impress than Office 365
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-08-27 15:43 UTC by Gerald Pfeifer
Modified: 2020-09-16 12:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample slides (PPTX) (1.83 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-08-27 15:43 UTC, Gerald Pfeifer
Details
Screenshot comparing Office 365 (top) and LO 7.1 (bottom) (105.49 KB, image/png)
2020-08-27 15:44 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-08-27 15:43:08 UTC
Created attachment 164759 [details]
Sample slides (PPTX)

How to reproduce:

 - open attached deck in Impress and Office 365
 - observe how the pie chart on both slides is much smaller (and placed
   differently) in Impress
Comment 1 Gerald Pfeifer 2020-08-27 15:44:15 UTC
Created attachment 164760 [details]
Screenshot comparing Office 365 (top) and LO 7.1 (bottom)
Comment 2 Gerald Pfeifer 2020-08-27 15:48:50 UTC
Seen with Version: 7.0.2.0.0+
Build ID: 5f305e6792c1c166b2a44a1e5085f42f53db50ea
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-08-26_00:15:32


Not seen (that badly) with Version: 6.4.4.2
Build ID: 40(Build:2)
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Comment 3 BogdanB 2020-08-27 20:02:42 UTC
Bibisected
 1cf157fe9d179e2f76ef699b23747d1ba530ebb4 is the first bad commit
commit 1cf157fe9d179e2f76ef699b23747d1ba530ebb4
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Jul 21 01:39:50 2020 +0200

    source sha:2bb5d9624911eb78ce5a3cd0aa122f9307c50a5c
    
    source sha:2bb5d9624911eb78ce5a3cd0aa122f9307c50a5c

 instdir/program/libchartcorelo.so | Bin 4559936 -> 4559936 bytes
 instdir/program/setuprc           |   2 +-
 instdir/program/versionrc         |   2 +-
 3 files changed, 2 insertions(+), 2 deletions(-)
Comment 4 Aron Budea 2020-09-11 21:51:36 UTC
(In reply to BogdanB from comment #3)
> Bibisected

When a single commit has been identified as the culprit, please add the keyword 'bisected' as well, and if the commit is fixing another bug, add that to the See Also field. It's also good to CC the committer.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2bb5d9624911eb78ce5a3cd0aa122f9307c50a5c
author		Balazs Varga <balazs.varga991@gmail.com>	2020-06-16 12:07:45 +0200
committer	Xisco Fauli <xiscofauli@libreoffice.org>	2020-06-25 12:18:50 +0200

"tdf#134029 Chart view: enable to move data label"

Bug not reproducible in 7.1.0.0.alpha0+ (63d4d3421fec5a4e9e88dcee2992cda38cc7452a) / Ubuntu.
However, label positioning isn't great, that might be worth a follow-up bug report.

Reverse-bibisected the fix to the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=57fedb272cfcad3436142dbe9eac2870e3c3e3d2
author		Balazs Varga <balazs.varga991@gmail.com>	2020-06-23 15:02:59 +0200
committer	László Németh <nemeth@numbertext.org>	2020-07-09 10:48:55 +0200

"tdf#134225 Chart view: fix moved date label"
Comment 5 Aron Budea 2020-09-11 21:52:53 UTC
(In reply to Aron Budea from comment #4)
> that to the See Also field. It's also good to CC the committer.
The author, not the committer.
Comment 6 Gerald Pfeifer 2020-09-15 20:00:39 UTC
(In reply to Aron Budea from comment #4)
> However, label positioning isn't great, that might be worth a follow-up bug
> report.

Is https://bugs.documentfoundation.org/show_bug.cgi?id=136235 sufficient
for that, or are you thinking of something else?

(Please feel free to improve the summary of that report of mine or add
any findings. Thank you!)
Comment 7 Xisco Faulí 2020-09-16 11:50:37 UTC
I do confirm the issue is fixed in

Version: 7.0.2.0.0+
Build ID: b27137a7091104cce177791478e86d127680c9af
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

(In reply to Gerald Pfeifer from comment #6)
> (In reply to Aron Budea from comment #4)
> > However, label positioning isn't great, that might be worth a follow-up bug
> > report.
> 
> Is https://bugs.documentfoundation.org/show_bug.cgi?id=136235 sufficient
> for that, or are you thinking of something else?
> 
> (Please feel free to improve the summary of that report of mine or add
> any findings. Thank you!)

Yes, I do confirm the labels were at a better position before 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=a4cdd4d1266e77330d4745f369db85ee7dba265c, so yes, bug 136235 tracks the same issue