Bug 136199 - LibreOffice Impress: unable to select cells in Table
Summary: LibreOffice Impress: unable to select cells in Table
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2020-08-27 17:22 UTC by Rafael Lima
Modified: 2021-09-16 22:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (17.70 KB, application/vnd.oasis.opendocument.presentation)
2020-09-12 22:20 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2020-08-27 17:22:39 UTC
When I add a table into an Impress presentation, it is impossible to select multiple cells. This would be useful when I need to format multiple cells at once (ex: to apply bold effect to some of the cells, increase font size or change background color).

However, when I click one of the cells and try to drag the mouse, the cells are not selected. I also tried by clicking a cell and then using the Shift key to click at another cell and select the range.

I made a short video showing the bug:
https://youtu.be/lcRt1V6qsNA

I am using LibreOffice 7.0.1 on Ubuntu 20.04 / Gnome 3.36 and Nvidia graphics.
Comment 1 BogdanB 2020-09-11 19:56:44 UTC
It works in
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded

Doesn't work in
Version: 7.1.0.0.alpha0+
Build ID: 3a22f5a589e822e7ca8bbb00e38a3aff93ed7ba5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 2 BogdanB 2020-09-11 20:06:41 UTC
Works in
Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Works in
Version: 6.4.4.1
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Works in
Version: 6.3.5.2
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 BogdanB 2020-09-11 20:14:55 UTC
I tried to bibisect this bug with 7.0 (all good) and 7.1 (all bad).
I don't understand.
Comment 4 BogdanB 2020-09-12 22:20:50 UTC
Created attachment 165436 [details]
test file

File for testing the selection
Comment 5 Rafael Lima 2020-09-14 16:45:20 UTC
I have just tried the test file in some newer builds and everything seems to be working fine. That is weird, because previously it was not working on my PC and these newer tests were done in the same PC with the same OS (Ubuntu 20.04.1)

WORKED FOR ME (I had not tested in this version before)
Version: 7.0.2.0.0+
Build ID: 181c737d5f2ed3718612dcafeaf458f5f147ce89
CPU threads: 16; OS: Linux 5.6; UI render: default; VCL: gtk3
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-09-12_22:57:45
Calc: CL

WORKED FOR ME (Was not working last time I checked)
Version: 7.1.0.0.alpha0+
Build ID: 83aa172697c11a9550c27a28f8e62b523ec7086d
CPU threads: 16; OS: Linux 5.6; UI render: default; VCL: gtk3
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-10_21:26:34
Calc: CL

WORKED FOR ME (Was not working last time I checked)
Version: 7.0.1.2
Build ID: 00(Build:2)
CPU threads: 16; OS: Linux 5.6; UI render: default; VCL: gtk3
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.1_rc2-0ubuntu0.20.04.1
Calc: CL
Comment 6 BogdanB 2020-09-14 17:37:42 UTC
Doesn't work for me in
Version: 7.1.0.0.alpha0+
Build ID: 3a22f5a589e822e7ca8bbb00e38a3aff93ed7ba5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded

it's very strange..
Comment 7 raal 2020-09-17 06:07:24 UTC
WFM Version: 7.1.0.0.alpha0+ (x64)
Build ID: bcf1917a0934417226d2357b514df398129a7fab
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: default; VCL: win

GTK3 only?
Comment 8 Rafael Lima 2020-09-18 15:55:50 UTC
I did some tests using KDE and found no issues. I used the test file provided above, as well as created new files and tried inserting new tables.

I tested the following versions of LibreOffice on Kubuntu 20.04 on my Dell laptop.

WORKS
Version: 6.4.6.2
Build ID: 1:6.4.6~rc2-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: GL; VCL: kf5; 
Locale: pt-BR (pt_BR.UTF-8); UI-Language: en-US
Calc: CL

WORKS
Version: 7.0.2.0.0+
Build ID: 181c737d5f2ed3718612dcafeaf458f5f147ce89
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-09-12_22:57:45
Calc: CL

WORKS
Version: 7.1.0.0.alpha0+
Build ID: 83aa172697c11a9550c27a28f8e62b523ec7086d
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-10_21:26:34
Calc: CL

I tested the following versions of LibreOffice on KDE Neon 5.19 on my desktop.

WORKS
Version: 7.0.2.0.0+
Build ID: 181c737d5f2ed3718612dcafeaf458f5f147ce89
CPU threads: 16; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-09-12_22:57:45
Calc: CL

WORKS
Version: 7.1.0.0.alpha0+
Build ID: 83aa172697c11a9550c27a28f8e62b523ec7086d
CPU threads: 16; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-10_21:26:34
Calc: CL

WORKS
Version: 7.0.1.2
Build ID: 00(Build:2)
CPU threads: 16; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.1~rc2-0ubuntu0.20.04.1
Calc: CL
Comment 9 Timur 2020-09-24 12:42:59 UTC
Sorry, this is strange report and confirmation that simple select cells doesn't work. It's only Bogdan now. I set back Needinfo. 
Of course you need to click in a cell first to select multiple cells. Otherwise table is selected.
Comment 10 Rafael Lima 2020-09-24 21:09:08 UTC
(In reply to Timur from comment #9)
> Of course you need to click in a cell first to select multiple cells.
> Otherwise table is selected.

Indeed this is very weird.

When I originally reported the bug, I posted a video and there you can see that I do click first and then try to select cells. And this happened multiple times on multiple files. That's why I recorded it and filed a bug.

But after some time the bug simply disappeared. Even when I use the version where the bug first appeared, I can't reproduce it any more.

If no one else can reproduce this bug, maybe this bug report should be closed.
Comment 11 QA Administrators 2020-09-25 03:57:54 UTC Comment hidden (obsolete)
Comment 12 Rafael Lima 2021-03-24 12:53:56 UTC
Just as an update to this bug report, I'd like to say that the bug persists in LO 7.1.1.2. Occasionally tables in Impress cannot be properly edited because one can't select multiple cells.

One important thing that I noted is that this bug happens alongside another bug, so I'll first explain this other problem. Suppose you add a text box in a slide, then edit the text and deselect it. Later you select it, edit the text again and press ESC. The expected behavior is to exit the edit mode and have the Text Box selected. This is also expected for tables and other objects.

However, there's some workflow that breaks this ESC key behavior (I couldn't figure out exactly the rule that breaks this). At some point, when you press ESC, you exit the edit mode and the text box (or any other objects) get deselected.

Whenever this bug starts to occur, table cells can no longer be selected. And this is a 1 to 1 correlation in my experience.

Another weird consequence of this bug is that even if you restart LO (close all of its applications and reopen), the ESC key bug persists. The only way around it is to restart the computer, then the bug is gone (at least until it comes up again).

I hope this helps pin down the root cause of this bug.
Comment 13 Rafael Lima 2021-03-24 13:24:40 UTC
May be related to this Bug 137093.
Comment 14 Timur 2021-03-24 16:55:22 UTC
We need sample document and reproducible steps. 
Both bugs are hard to track down.
Comment 15 BogdanB 2021-03-25 08:20:09 UTC
Working well in
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5262a9e88037decc26da84e7fa62f2955d4cdb85
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Working well also in
Version: 7.1.1.2 / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Can we close the bug? Is anyone else reproducing this bug in the latest versions?
Comment 16 Timur 2021-03-25 08:30:05 UTC
Let's keep in Needinfo.
Comment 17 Rafael Lima 2021-03-25 17:39:28 UTC
> Can we close the bug? Is anyone else reproducing this bug in the latest
> versions?

Hi Bogdan. Let's wait a few more days because I'm trying to figure out a sequence of steps to reproduce the bug.

Unfortunately this bug seems to be caused by some sequence of steps (clicks in the UI), so it's not possible to prepare a Test File.

This weekend I'll be using LO Impress a lot to prepare lectures, so I'll certainly experience this bug again. As soon as it happens, I'll try to take notes of the context where it happens.
Comment 18 QA Administrators 2021-03-26 04:21:42 UTC Comment hidden (obsolete)
Comment 19 Timur 2021-09-16 14:08:08 UTC
No steps so I close. 
There's something here, See also another report, but not reproducible. 
If you find steps, please set Unconfirmed again.
Comment 20 Timur 2021-09-16 14:08:31 UTC
And see bug 117484.
Comment 21 Rafael Lima 2021-09-16 22:11:40 UTC
(In reply to Timur from comment #19)
> No steps so I close. 
> There's something here, See also another report, but not reproducible. 
> If you find steps, please set Unconfirmed again.

Hi Timur. For the time being I agree with your resolution, so let's keep it as INSUFFICIENTDATA unless I can find the exact sequence to reproduce it.

On LO 7.1 I ran into this issue all the time. If you create a more complex table and keep editing it long enough, this issue will occur. But I could not determine the correct steps that lead to it.

I have been using LO 7.2 for a couple of weeks and still have not ran into this issue. Hope it is gone now.