Bug 136230 - SPECIAL CHARACTER DIALOG: Results of search field are not displayed after font changing
Summary: SPECIAL CHARACTER DIALOG: Results of search field are not displayed after fon...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://ask.libreoffice.org/en/questi...
Whiteboard:
Keywords:
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2020-08-28 14:43 UTC by shariqkeen
Modified: 2021-03-15 08:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shariqkeen 2020-08-28 14:43:18 UTC
Regarding search functionality from insert special characters>more characters. Searching by using the names of characters often gives no result. There seem to be no pattern, just keep trying by changing the font and it will give results randomly sometimes.

Chances of getting results increases, I feel from my experience but not sure, if before writing the name of character the default font is toggled to any other.

My few observations below [for a fresh doc everytime, my default is noto sans but it should occur with others too just try a few combinations randomly for search terms 'check' or 'ballot x' or any, also try by toggling font prior to writing the search term]:

search 'check' with Noto sans as default [no result] > change noto sans to opensymbol [no result] > select opensymbol again [success]

change default noto sans to opensymbol first > search 'check' [success] > change opensymbol to Padauk [success] > change Padauk to opensymbol again [no result] > select opensymbol again [success]

change default noto sans to Padauk first > search 'check' [no result] > change Padauk to opensymbol [no result] > change to Padauk again [success]

Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
Calc: threaded
Comment 2 Dieter 2020-11-26 07:15:34 UTC
PLease have a look at the bug I've reported (bug 138193). Will a better documentation solve your problem?
=> NEEDINFO
Comment 3 shariqkeen 2020-11-26 22:39:39 UTC
(In reply to Dieter from comment #2)
> PLease have a look at the bug I've reported (bug 138193). Will a better
> documentation solve your problem?
> => NEEDINFO

No, it's not about documentation at all but search ability/efficiency.
Comment 4 Dieter 2021-03-15 08:28:14 UTC
I confirm it with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 21c602913d98ef46b49fc9b6f9071db92a1597c6
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Steps to reproduce
1. Open Special Character Dialog
2. Select "Noto Sans" as font
3. Type "check" in search field => no result (expected)
4. Change font to "OpenSymbol" => no result (not expected)
5. Select again "OpenSymbol" as font => results are displayed