Download it now!
Bug 136287 - Certain properties of controls in forms can no longer be edited using keyboard entries.
Summary: Certain properties of controls in forms can no longer be edited using keyboa...
Status: RESOLVED DUPLICATE of bug 134725
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-08-30 12:54 UTC by Kadet
Modified: 2021-01-04 06:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Scrin (137.51 KB, image/jpeg)
2020-08-30 12:55 UTC, Kadet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kadet 2020-08-30 12:54:56 UTC
Description:
In LO7. 0. 0. 3 and the following in the form editor, the "element properties" functionality stopped working.
The color of the text (button) does not change.
The font size doesn't change.
The width, height, and position of the element does not change.
Etc.

Steps to Reproduce:
1.Create a Form in any LO app
2.In the form editor mode, create a "button" form element.
3.Right-click on the "button" element.
4.Open "element properties".
5. To change the values of item properties: Height, Width, X Position, Y Position, font Color, etc.
6.The element property values do not change. The element does not change.

Actual Results:
The element does not change when its properties are changed.

Expected Results:
The element must change when its properties change.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
In LO 6.4 and earlier, everything changed.
Comment 1 Kadet 2020-08-30 12:55:23 UTC
Created attachment 164874 [details]
Scrin
Comment 2 Kadet 2020-08-30 13:04:22 UTC
I did all this in LO Base
Comment 3 Kadet 2020-08-30 13:10:51 UTC
If you change these properties with a macro, nothing changes either.
Comment 4 Robert Großkopf 2020-08-30 13:34:27 UTC
Can't confirm this behavior for LO 7.0.0.3 on OpenSUSE 64bit rpm Linux. All controls could be changed in every property here.
Comment 5 Kadet 2020-08-30 14:06:16 UTC
I have windows 7 (10)
Comment 6 Kadet 2020-08-30 16:09:15 UTC
If you change values using the up-and-down arrows next to the value fields instead of using the keyboard, everything changes. And if you type it on the keyboard , it doesn't change.
Comment 7 Alex Thurgood 2020-09-14 07:53:39 UTC
Confirming that direct entry of manual coordinates in control properties is not reflected on the form. I seem to recall that this is a known bug that was recently fixed, however.

I can also confirm that the colour of the text of a Button control does not change when changed via the colour selection palette. This might also be a known bug, separate from the positioning one.

Confirming at least the first one, but pretty certain that these are duplicates. 

Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 8 Aron Budea 2021-01-04 06:55:14 UTC
Reproduced and bibisected to the following commit using repo bibisect-linux-64-7.0, which is the same commit as bug 134725's. Let's mark this as duplicate.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1efeb17837c22499f00299c033ae59ba3910f7d7
author		Caolán McNamara <caolanm@redhat.com>	2019-11-04 13:06:04 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-09 13:28:35 +0100

"weld Property Browser"

(In reply to Alex Thurgood from comment #7)
> I can also confirm that the colour of the text of a Button control does not
> change when changed via the colour selection palette. This might also be a
> known bug, separate from the positioning one.
This other bug is fixed in 7.1.0.1.

*** This bug has been marked as a duplicate of bug 134725 ***