Download it now!
Bug 136304 - The spell checker doesn't mark words wrong spelled by default if there is a number written at beginning/ end or somewhere within
Summary: The spell checker doesn't mark words wrong spelled by default if there is a n...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2020-08-30 19:10 UTC by Telesto
Modified: 2020-09-23 10:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.92 KB, application/vnd.oasis.opendocument.text)
2020-08-30 19:10 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-30 19:10:19 UTC
Description:
The spell checker doesn't mark words wrong spelled if there is a number written at beginning/ end or somewhere within

Steps to Reproduce:
1. open the attached file
2. Look at the red lining

Actual Results:
Nothing misspelled

Expected Results:
I would expect they spell checker being trigger, bit to tolerant for my taste 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: lb-LU (nl_NL); UI: en-US
Calc: CL

and 
3.3.0
Comment 1 Telesto 2020-08-30 19:10:31 UTC
Created attachment 164894 [details]
Example file
Comment 2 Telesto 2020-08-30 19:17:13 UTC
@László Németh
The Hunspell expert. Feature or bug. Looks like a bug to me.
 
Outside the scope of this, I would also expect a sensible suggestion for "He^llo" But noticing more spell checkers having trouble with that.
Comment 3 Regina Henschel 2020-08-30 23:25:10 UTC
The desired behavior can be set from the user in Tools > Options > Language Settings > Writing Aids.
Option "Check words with numbers" in section "Options".

No bug.
Comment 4 Telesto 2020-08-31 07:58:06 UTC
(In reply to Regina Henschel from comment #3)
> The desired behavior can be set from the user in Tools > Options > Language
> Settings > Writing Aids.
> Option "Check words with numbers" in section "Options".

Thanks for that :-). So not a developers 'fault'. Let's carry on the next station. UX. As this is of course not something I don't let go easily. Even though there appears to be not 'common' setting for this.

I'm still a proponent for dialog to configure LibreOffice. At for 'more' common disputable settings.. to make it more accessible and raise awareness of the existence. The scattered all over the place; buried deep within dialogs. It's common that Benjamins like me are not able to find it; realize it's a setting (and call it a bug) 

Some suggestions:
* Markdown auto-correct
* Check words with numbers exception
* Autocomplete [Someone decided to disable it by default]
* Highlighting or shading
* Tabbed or Toolbar
* Autocaption
* Grid enable/disable

Maybe even show it at first launch. As there is already a debate about a configuration 'wizard' related to the UI (toolbar/tabbed)
Comment 5 Heiko Tietze 2020-09-23 10:25:39 UTC
The options under writing aids are also relevant for the auto spellcheck function. That means, it needs a central place for configuration.
We have a big button in the spell checking dialog to get to these options (without any distraction). 
Words with 1numbers at the beginning are easy to spot; and you may understand why a corrections is not done without reading the documentation. 

Putting all together I think every additional feedback has not much benefit on usability but clutters the UI and performs worse than today => NAB