Download it now!
Bug 136504 - EDITING: Backspace does not move the cursor to the left of a character recorded as deleted by "track changes"
Summary: EDITING: Backspace does not move the cursor to the left of a character record...
Status: RESOLVED DUPLICATE of bug 135260
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-09-05 22:15 UTC by Victor
Modified: 2020-09-22 14:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor 2020-09-05 22:15:21 UTC
Description:
When "track changes" is activated and visible, it is not possible to move the cursor to the left of a deleted character, i.e. the strike-through ones, by pressing backspace. This results, for example, in the impossibility to delete more than one character at a time when track changes are recorded and visible.

Steps to Reproduce:
1. Activate track changes recording (edit > track changes > Record) and make the changes visible (edit > track changes > show) 
2. Try to delete some text by pressing backspace
3. Or set your cursor to the right of character recorded as deleted, i.e. marked as stroked-through

Actual Results:
cursor does not move to the left of the deleted character, making it impossible to delete more than one character at a time or navigate trough text marked as deleted using the backspace key

Expected Results:
cursor should have shifted to the left


Reproducible: Always


User Profile Reset: No



Additional Info:
Tested on Debian Buster and Manjaro (both using KDE desktop)

Writer 6.4.4.2 is working as expected

delete key is working as expected even in Writer 7.0.0.3 (i.e. cursor moves to the right of previously deleted character)
Comment 1 pierre-yves samyn 2020-09-18 17:07:49 UTC
Hi 

I reproduce the problem on windows & Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded

Also reproduced on Ask/fr: 
https://ask.libreoffice.org/fr/question/266573/suivi-de-modification-suppression-dune-lettre-a-la-fois/

I change status to NEW

Best regards
Comment 2 Attila Baraksó (NISZ) 2020-09-22 14:01:40 UTC

*** This bug has been marked as a duplicate of bug 135260 ***