Bug 136522 - FILESAVE: additional row of the same background color makes that color disappear after BL column
Summary: FILESAVE: additional row of the same background color makes that color disapp...
Status: RESOLVED DUPLICATE of bug 133327
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, dataLoss
Depends on:
Blocks:
 
Reported: 2020-09-06 18:13 UTC by Jerome
Modified: 2020-09-07 08:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot illustrating the issue (564.75 KB, image/jpeg)
2020-09-06 18:13 UTC, Jerome
Details
video showing the bug (1.10 MB, video/mp4)
2020-09-06 19:51 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jerome 2020-09-06 18:13:37 UTC
Created attachment 165205 [details]
screenshot illustrating the issue

This issue happened on several computers either with the 7.0.0.3 and 6.4.6.2 releases.

From a new spreadsheet, if I fill several cells with any color, all background cells after column BL are not saved.
It saves thing properly up to columns where some text exist (except some columns before BL who do not need anything). See attached screenshots.
Comment 1 Julien Nabet 2020-09-06 18:52:32 UTC Comment hidden (obsolete)
Comment 2 BogdanB 2020-09-06 19:51:22 UTC
Confirmed in
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded

See video.
Comment 3 BogdanB 2020-09-06 19:51:42 UTC
Created attachment 165208 [details]
video showing the bug
Comment 4 Jerome 2020-09-07 01:46:09 UTC
it happens on any file. Both computers I tried were up to date Ubuntu Mate 20.04 if that can help ...
Comment 5 Julien Nabet 2020-09-07 06:12:56 UTC
I still can't reproduce this even after having watched the video and tried again=>uncc myself.
Comment 6 Timur 2020-09-07 08:04:10 UTC
Good catch by the reporter, nasty bug. 
When bug is reported for 7.0, it needs both to be tested with 7.0 and master. 

With 7.0 oldest, bug is easily reproducible, first save of background cells after column BL truncates the background. 
With 7.0 latest and 7.1+ master, bug is different: additional row of the same background color makes that color disappear after BL column.

Steps
1. add background (like yellow) to cells before and after BL column, save and reopen, see all fine
2. optional: add 2nd color, maybe 3rd color..., just once, save, reopen, fine
3. add additional row of any of those colors. save, reopen, see just those 2 rows missing background after BL

So, this is improvement, but still wrong. Bibisect would be helpful, and search for existing bug.
Comment 7 Timur 2020-09-07 08:11:18 UTC
Rule of thumb: search before reporting and confirming.

*** This bug has been marked as a duplicate of bug 133327 ***