Bug 136546 - Crash when loading xlsx spreadsheet with many columns
Summary: Crash when loading xlsx spreadsheet with many columns
Status: RESOLVED DUPLICATE of bug 109061
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-09-07 11:04 UTC by Felix Schwarz
Modified: 2022-02-14 12:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file (913.64 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-09-17 09:18 UTC, Xisco Faulí
Details
backtrace (15.94 KB, text/plain)
2020-09-24 20:51 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Schwarz 2020-09-07 11:04:11 UTC
Description:
I'm using LibreOffice 7.0.1.2 from Flathub on Fedora 32. I enabled the experimental feature "very large spreadsheets (16m rows, 16384 cols)".

However LibreOffice crashes when loading loading this file: 
https://drive.google.com/open?id=0B2zOYKo2xAjcMXQ2enZsaVo4Wms

I tried this on fresh Unix account so I believe this should happen to every new users. I guess this bug should be linked to bug 133764.

I could not select my version ("7.0.1.2") in the Version field so I used the nearest I could find ("7.0.0.3").

Steps to Reproduce:
1. Load the linked file

Actual Results:
crash

Expected Results:
should be able to work with the data inside the spreadsheat


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 12; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Flatpak
Calc: threaded
Comment 1 Xisco Faulí 2020-09-07 11:36:03 UTC
The feature 'very large spreadsheets' is very unstable at the moment and I don't recommend it to use it unless you want to face crashes left and right.
Closing as dupe of bug 134392

*** This bug has been marked as a duplicate of bug 134392 ***
Comment 2 Xisco Faulí 2020-09-17 09:08:25 UTC
Still reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 6f1e02c96b887750f974c187a82ecd6236e6a435
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Xisco Faulí 2020-09-17 09:18:20 UTC
Created attachment 165613 [details]
sample file
Comment 4 Terrence Enger 2020-09-24 20:51:34 UTC
Created attachment 165822 [details]
backtrace

The backtrace is from commit b42d5557 (2020-09-10) opening the
attached file, built and running on debian-buster, configured:

    --with-vendor=Terrence Enger
    --with-jdk-home=/usr/lib/jvm/default-java
    --enable-split-debug
    --enable-gdb-index
    --enable-ld=gold
    --enable-option-checking=fatal
    #--enable-dbgutil
    --enable-debug
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
    --without-package-format

I am adding keyword haveBacktrace.
Comment 5 Luboš Luňák 2022-02-14 12:23:18 UTC

*** This bug has been marked as a duplicate of bug 109061 ***